aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-16 17:37:43 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:43 +0530
commitabf6e95662c6859c1104d85578f127dfc18c5186 (patch)
tree0b8ff924598fa5c82b45d182b8e2e0efba9fbb7b /gnu
parentce7520db90d86e3db9fe4f3fa267e5586a42ab20 (diff)
downloadguix-abf6e95662c6859c1104d85578f127dfc18c5186.tar.gz
guix-abf6e95662c6859c1104d85578f127dfc18c5186.zip
gnu: Add rust-alloc-stdlib-0.2.
* gnu/packages/crates-io.scm (rust-alloc-stdlib-0.2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 791c2d87c7..0b90d9d47e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -414,6 +414,28 @@ options to use calloc or a mutable global variable for pre-zeroed memory.")
(define-public rust-alloc-no-stdlib-2.0 rust-alloc-no-stdlib-2)
+(define-public rust-alloc-stdlib-0.2
+ (package
+ (name "rust-alloc-stdlib")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "alloc-stdlib" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hj3r1x88aajnvigdck0diygj2isc90wa271kkj1swgiq3nxfzk9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-alloc-no-stdlib" ,rust-alloc-no-stdlib-2.0))))
+ (home-page "https://github.com/dropbox/rust-alloc-no-stdlib")
+ (synopsis "A dynamic allocator example that may be used with the stdlib")
+ (description "This package provides a dynamic allocator example that may
+be used with the stdlib.")
+ (license license:bsd-3)))
+
(define-public rust-android-glue-0.2
(package
(name "rust-android-glue")