aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-06-23 13:48:49 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-07-03 09:56:14 +0200
commitaae5f41b3686da0c91922ee7837c5e61c3fbc6b1 (patch)
tree8e21903e313c9e2f781593ecaf9194a45325628f /gnu
parent3f055028ac202763534bb203ebf3edd6a8eeedfb (diff)
downloadguix-aae5f41b3686da0c91922ee7837c5e61c3fbc6b1.tar.gz
guix-aae5f41b3686da0c91922ee7837c5e61c3fbc6b1.zip
gnu: Add r-mlrmbo.
* gnu/packages/cran.scm (r-mlrmbo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a4c5a9f01e..5dd199b216 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35306,6 +35306,40 @@ Also included:
Most operations can be parallelized.")
(license license:bsd-2)))
+(define-public r-mlrmbo
+ (package
+ (name "r-mlrmbo")
+ (version "1.1.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mlrMBO" version))
+ (sha256
+ (base32
+ "16fwj7m28g4km7yalqppxmh3lw2jln0z072l6awia38qkdg6xwhc"))))
+ (properties `((upstream-name . "mlrMBO")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-backports
+ r-bbmisc
+ r-checkmate
+ r-data-table
+ r-lhs
+ r-mlr
+ r-parallelmap
+ r-paramhelpers
+ r-smoof))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/mlr-org/mlrMBO")
+ (synopsis "Model-based optimization with mlr")
+ (description
+ "This package is a flexible and comprehensive R toolbox for model-based
+optimization. It implements Efficient Global Optimization Algorithm for
+single- and multi-objective optimization. It supports mixed parameters. The
+machine learning toolbox mlr offers regression learners. It provides various
+infill criteria and features batch proposal, parallel execution,
+visualization, and logging. Its modular implementation allows easy
+customization by the user.")
+ (license license:bsd-2)))
+
(define-public r-mlr3measures
(package
(name "r-mlr3measures")