aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-17 23:05:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:24 +0100
commitaa0650d159ba9a7aaac6bd29f0279b4d4c4709ad (patch)
tree6362a90e2c1be6a10ca64b74c39529509fd636a5 /gnu
parentf0739f3ae454f74b27ed5adc8951a8d8ebb91356 (diff)
downloadguix-aa0650d159ba9a7aaac6bd29f0279b4d4c4709ad.tar.gz
guix-aa0650d159ba9a7aaac6bd29f0279b4d4c4709ad.zip
gnu: python-pythran: Update to 0.17.0.
* gnu/packages/python-science.scm (python-pythran): Update to 0.17.0. [build-system]: Use pyproject-build-system. [source]: Remove obsolete snippet. [arguments]: Remove phase 'do-not-install-third-parties and custom 'check phase; use #:test-flags and add 'pre-check phase. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I49ebdd21cfb0668dd84f0d12c460a86ed694c7d6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm63
1 files changed, 29 insertions, 34 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 36950a8638..718c482037 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1666,49 +1666,44 @@ y, z)}.")
(define-public python-pythran
(package
(name "python-pythran")
- (version "0.11.0")
+ (version "0.17.0")
(home-page "https://github.com/serge-sans-paille/pythran")
(source (origin
(method git-fetch)
(uri (git-reference (url home-page) (commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0cm7wfcyvkp1wmq7n1lyf2d3sj6158jf63bagjpjmfnjwij19n0p"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove bundled Boost and xsimd.
- (delete-file-recursively "third_party")))))
- (build-system python-build-system)
+ (base32 "1rm9lfbz5qvah1m0rr5gaaahkf1gzwlw1ysvym2l2yh0clglav94"))))
+ (build-system pyproject-build-system)
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'do-not-install-third-parties
- (lambda _
- (substitute* "setup.py"
- (("third_parties = .*")
- "third_parties = []\n"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Remove compiler flag that trips newer GCC:
- ;; https://github.com/serge-sans-paille/pythran/issues/908
- (substitute* "pythran/tests/__init__.py"
- (("'-Wno-absolute-value',")
- ""))
- (setenv "HOME" (getcwd))
- ;; This setup is modelled after the upstream CI system.
- (call-with-output-file ".pythranrc"
- (lambda (port)
- (format port "[compiler]\nblas=openblas~%")))
- (invoke "pytest" "-vv"
- (string-append "--numprocesses="
- (number->string
- (parallel-job-count)))
- "pythran/tests/test_cases.py")))))))
+ (list
+ #:test-flags
+ '(list (string-append "--numprocesses=" (number->string
+ (parallel-job-count)))
+ ;; XXX There are lots of tests of the format
+ ;; pythran/tests/test_*.py, but they cannot easily be selected.
+ "pythran/tests/test_typing.py")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Remove compiler flag that trips newer GCC:
+ ;; https://github.com/serge-sans-paille/pythran/issues/908
+ (substitute* "pythran/tests/__init__.py"
+ (("'-Wno-absolute-value',") ""))
+ (setenv "HOME" (getcwd))
+ ;; This setup is modelled after the upstream CI system.
+ (call-with-output-file ".pythranrc"
+ (lambda (port)
+ (format port "[compiler]\nblas=openblas~%")))))))))
(native-inputs
;; For tests.
- (list openblas python-pytest python-pytest-xdist))
+ (list openblas
+ python-pytest
+ python-pytest-xdist
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list boost xsimd ;headers need to be available
python-beniget python-gast python-numpy python-ply))