aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-09 19:53:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-09 19:54:27 +0200
commita9bd722d671a2b6e2742c44334c6c83bc66fc6e9 (patch)
treef8dac030c772555aad7d3fe85b8c1309ad977da1 /gnu
parent0f7d8a83056054a8c3071b157184918070288900 (diff)
downloadguix-a9bd722d671a2b6e2742c44334c6c83bc66fc6e9.tar.gz
guix-a9bd722d671a2b6e2742c44334c6c83bc66fc6e9.zip
gnu: python-fastapi: Do not delete tests, and add orjson.
* gnu/packages/python-web.scm (python-fastapi)[arguments]: Remove all custom phases; ignore two test files. [propagated-inputs]: Add python-orjson.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 5 insertions, 21 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 99853acec5..486414c3f1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8287,32 +8287,16 @@ Interface) framework/toolkit for building async web services in Python.")
(build-system pyproject-build-system)
(arguments
(list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'drop-orjson
- (lambda _
- (substitute* "pyproject.toml"
- (("\"orjson.*\",") ""))))
- (add-after 'unpack 'delete-failing-tests
- (lambda _
- (for-each
- delete-file
- (append
- '("docs_src/app_testing/app_b_py310/test_main.py"
- "tests/test_tutorial/test_templates/test_tutorial001.py")
- (find-files "docs_src/sql_databases/"
- "test_sql_app\\.py$")
- (find-files "tests"
- "test_(default|orjson)_response_class\\.py$")
- (find-files "tests/test_tutorial"
- "test_tutorial00(1b|9c)\\.py$")
- (find-files "tests/test_tutorial"
- "test_testing_databases.*\\.py$"))))))))
+ #:test-flags
+ ;; The test_create_user tests fail with a 400 error: "Email already registered".
+ '(list "--ignore=docs_src/sql_databases/sql_app_py310/tests/test_sql_app.py"
+ "--ignore=docs_src/sql_databases/sql_app_py39/tests/test_sql_app.py")))
(propagated-inputs (list python-email-validator
python-httpx
python-itsdangerous
python-jinja2
python-multipart
+ python-orjson
python-starlette
python-pydantic
python-pyyaml