aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2024-10-31 00:26:00 +0000
committerLudovic Courtès <ludo@gnu.org>2024-12-18 13:22:47 +0100
commita7dfb0428800b39e232dc5ce14b424ef40db100a (patch)
tree298c5dbec88c6ebf217ff9d036d1d8980cc82c43 /gnu
parent993fd945d11f967c78fa1ed337a37a2a9644b5a4 (diff)
downloadguix-a7dfb0428800b39e232dc5ce14b424ef40db100a.tar.gz
guix-a7dfb0428800b39e232dc5ce14b424ef40db100a.zip
gnu: Add julia-argcheck.
* gnu/packages/julia-xyz.scm (julia-argcheck): New variable. Change-Id: I0cef75b36ea3de1af1b9ed6469af5b687495e436 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b30bddf48b..499678825b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -148,6 +148,27 @@ ANSI escape codes to another format.")
provides functions to run a few automatable checks for Julia packages.")
(license license:expat)))
+(define-public julia-argcheck
+ (package
+ (name "julia-argcheck")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jw3126/ArgCheck.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13mkcq4ln1vm9hxk3rxs6gcrddbs01bapvp3wb39xqvpb6q3fv6h"))))
+ (build-system julia-build-system)
+ (native-inputs (list julia-benchmarktools))
+ (home-page "https://github.com/jw3126/ArgCheck.jl")
+ (synopsis "Package for checking function arguments")
+ (description "This package provides a method to ensure that arguments
+to a function conform to a specification.")
+ (license license:expat)))
+
(define-public julia-arnoldimethod
(package
(name "julia-arnoldimethod")