aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-22 16:34:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:41 +0200
commita7d7795f97c2eccc2a1f6527a412d8a9ab4c21d0 (patch)
tree4426dc23f1799b1b96fe5332194233dbadafcaa8 /gnu
parentd1c5beea1fa05fbd7f965fc17631dec89a938f1f (diff)
downloadguix-a7d7795f97c2eccc2a1f6527a412d8a9ab4c21d0.tar.gz
guix-a7d7795f97c2eccc2a1f6527a412d8a9ab4c21d0.zip
gnu: rust-hickory-resolver-0.24: Update to 0.24.1.
* gnu/packages/crates-web.scm (rust-hickory-resolver-0.24): Update to 0.24.1. Change-Id: Ic60926bd33c1c7114d0b33cc84164f7cc1c6b966
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-web.scm42
1 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index a98e12d0b7..4774a119d0 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2968,14 +2968,14 @@ performing recursive lookups.")
(define-public rust-hickory-resolver-0.24
(package
(name "rust-hickory-resolver")
- (version "0.24.0")
+ (version "0.24.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "hickory-resolver" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1s3486qczv9gaw8dap06c0bwb2bpqm23a0ihj169hsjf2qhz1f1m"))))
+ (base32 "0hzjn5wpchljcsk51c1156rk3f15iinmwh7h9hjqzjbmm8ipyx98"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-test-flags
@@ -2996,25 +2996,25 @@ performing recursive lookups.")
"--skip=resolver::tests::test_lookup"
"--skip=system_conf::unix::tests::test_read_resolv_conf")
#:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
- ("rust-futures-util" ,rust-futures-util-0.3)
- ("rust-hickory-proto" ,rust-hickory-proto-0.24)
- ("rust-ipconfig" ,rust-ipconfig-0.3)
- ("rust-lru-cache" ,rust-lru-cache-0.1)
- ("rust-once-cell" ,rust-once-cell-1)
- ("rust-parking-lot" ,rust-parking-lot-0.12)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-resolv-conf" ,rust-resolv-conf-0.7)
- ("rust-rustls" ,rust-rustls-0.21)
- ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.6)
- ("rust-serde" ,rust-serde-1)
- ("rust-smallvec" ,rust-smallvec-1)
- ("rust-thiserror" ,rust-thiserror-1)
- ("rust-tokio" ,rust-tokio-1)
- ("rust-tokio-native-tls" ,rust-tokio-native-tls-0.3)
- ("rust-tokio-openssl" ,rust-tokio-openssl-0.6)
- ("rust-tokio-rustls" ,rust-tokio-rustls-0.24)
- ("rust-tracing" ,rust-tracing-0.1)
- ("rust-webpki-roots" ,rust-webpki-roots-0.25))
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-hickory-proto" ,rust-hickory-proto-0.24)
+ ("rust-ipconfig" ,rust-ipconfig-0.3)
+ ("rust-lru-cache" ,rust-lru-cache-0.1)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-parking-lot" ,rust-parking-lot-0.12)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-resolv-conf" ,rust-resolv-conf-0.7)
+ ("rust-rustls" ,rust-rustls-0.21)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.6)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-smallvec" ,rust-smallvec-1)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-native-tls" ,rust-tokio-native-tls-0.3)
+ ("rust-tokio-openssl" ,rust-tokio-openssl-0.6)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.24)
+ ("rust-tracing" ,rust-tracing-0.1)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.25))
#:cargo-development-inputs
(("rust-futures-executor" ,rust-futures-executor-0.3)
("rust-tokio" ,rust-tokio-1)