aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-05 19:15:47 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:02 +0000
commita68c7e4fc6dc0bc75f10d5ee2de9dea1439a3cf0 (patch)
treee05d98e297edc34ddfaec505a9e6fd1a7e01b864 /gnu
parent4b8d10ffdb0b2cf9aaf5e774cea6fc56bd9662d1 (diff)
downloadguix-a68c7e4fc6dc0bc75f10d5ee2de9dea1439a3cf0.tar.gz
guix-a68c7e4fc6dc0bc75f10d5ee2de9dea1439a3cf0.zip
gnu: python-twine: Adjust inputs.
* gnu/packages/python-xyz.scm (python-twine): Adjust inputs, fix biuld. [arguments]<test-flags>: Refresh the list of disabled tests. [native-inputs]: Add python-setuptools, python-setuptools-scm, and python-wheel. Change-Id: I29904649c2d9ab1994e057f5434b5052ca8602cf
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dbbe966db1..a03e9bf21e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26425,12 +26425,21 @@ created by running @code{python setup.py develop}).")
(arguments
(list #:test-flags ;; Disable failing tests.
#~(list "-k" (string-append
- "not test_pkginfo_returns_no_metadata"
- " and not test_fails_rst_no_content"))))
+ "not test_fails_rst_no_content"
+ " and not test_fails_rst_syntax_error"
+ " and not test_passes_markdown_description[text/markdown]"
+ " and not test_passes_markdown_description[text/plain]"
+ " and not test_passes_rst_description"
+ " and not test_warns_missing_description[False]"
+ " and not test_warns_missing_description[True]"
+ " and not test_warns_missing_file"))))
(native-inputs
(list python-pretend
python-pytest
- python-pytest-socket))
+ python-pytest-socket
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-importlib-metadata
python-keyring