aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-20 16:00:40 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:04 -0400
commita621b527acb4d011747a183f901a3158837c1fe5 (patch)
treee0c35c77c28232937f28412a7bc7e84a02d511a1 /gnu
parent87e7c6dcf516bd0e06c58dc787658891dba0ee5a (diff)
downloadguix-a621b527acb4d011747a183f901a3158837c1fe5.tar.gz
guix-a621b527acb4d011747a183f901a3158837c1fe5.zip
gnu: libgsf: Remove patch-docbook-xml phase.
* gnu/packages/gnome.scm (libgsf) [arguments]: Remove patch-docbook-xml phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm46
1 files changed, 18 insertions, 28 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e52a543db6..6d965aa212 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3425,34 +3425,24 @@ XML/CSS rendering engine.")
(build-system glib-or-gtk-build-system)
(outputs '("out" "bin" "doc"))
(arguments
- (list
- #:configure-flags
- #~(list
- "--disable-static"
- "--enable-introspection"
- (string-append "--with-gir-dir=" #$output
- "/share/gir-"
- #$(version-major
- (package-version gobject-introspection))
- ".0")
- (string-append "--with-typelib-dir=" #$output
- "/lib/girepository-"
- #$(version-major
- (package-version gobject-introspection))
- ".0")
- (string-append "--with-html-dir=" #$output
- "/share/gtk-doc/html")
- "--with-zlib"
- "--with-bz2")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-docbook-xml
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (with-directory-excursion "doc"
- (substitute* "gsf-docs.xml"
- (("http://www.oasis-open.org/docbook/xml/4.5/")
- (search-input-directory (or native-inputs inputs)
- "xml/dtd/docbook")))))))))
+ (list #:configure-flags
+ #~(list
+ "--disable-static"
+ "--enable-introspection"
+ (string-append "--with-gir-dir=" #$output
+ "/share/gir-"
+ #$(version-major
+ (package-version gobject-introspection))
+ ".0")
+ (string-append "--with-typelib-dir=" #$output
+ "/lib/girepository-"
+ #$(version-major
+ (package-version gobject-introspection))
+ ".0")
+ (string-append "--with-html-dir=" #$output
+ "/share/gtk-doc/html")
+ "--with-zlib"
+ "--with-bz2")))
(native-inputs
(list docbook-xml
gettext-minimal
7 18:00:28 -0500'>2020-11-17Merge remote-tracking branch 'origin/version-1.2.0' into master...Maxim Cournoyer 2020-11-16.dir-locals.el: Add upstream report link....Miguel Ángel Arruga Vivas 2020-11-16.dir-locals.el: Use setq-local on guix-directory....Christopher Lemmer Webber 2020-11-16.dir-locals.el: Prevent errors if .dir-locals.el isn't found....Christopher Lemmer Webber 2020-11-12maint: update-guix-package: Optionally add sources to store....Maxim Cournoyer 2020-11-01.dir-locals.el: Require cl-lib at runtime....Miguel Ángel Arruga Vivas 2020-10-31.dir-locals.el: Automatically set the GEISER-GUILE-LOAD-PATH variable....Maxim Cournoyer 2020-10-19maint: update-guix-package: Prevent accidentally breaking guix pull....Maxim Cournoyer 2020-09-14deduplication: pass store directory to replace-with-link....Caleb Ristvedt 2020-09-14.dir-locals.el: fix call-with-{retrying-}transaction indenting....Caleb Ristvedt 2020-08-26.dir-locals.el: Add indentation rule for 'package/inherit'....Ludovic Courtès 2020-06-25deduplication: Use 'dynamic-wind' when changing permissions of the parent....Ludovic Courtès 2020-06-16channels: 'latest-channel-instance' authenticates Git checkouts....Ludovic Courtès 2020-06-10database: separate transaction-handling and retry-handling....Caleb Ristvedt 2020-06-10database: ensure update-or-insert is run within a transaction...Caleb Ristvedt 2020-06-10database: rewrite query procedures in terms of with-statement....Caleb Ristvedt 2020-06-06ui: 'display-search-results' automatically invokes the pager....Ludovic Courtès 2020-06-05git-authenticate: Add tests....Ludovic Courtès 2020-05-16gexp: Add 'let-system'....Ludovic Courtès