aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-19 23:37:24 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:26 +0200
commita45e4bc5c219f143169a1b1a0e6bf02af9910f3b (patch)
tree9c3d1f3ba38119175afd6fb374cb1fbfd5201a8a /gnu
parente81fab29e7b6c4b06dca1f4f3a2a73f09a666436 (diff)
downloadguix-a45e4bc5c219f143169a1b1a0e6bf02af9910f3b.tar.gz
guix-a45e4bc5c219f143169a1b1a0e6bf02af9910f3b.zip
gnu: gammastep: Add bash-minimal to inputs.
* gnu/packages/xdisorg.scm (gammastep) [inputs]: Add bash-minimal. [arguments]: Delete trailing #t. Change-Id: I8ab8b8b6293aaf5bf907003044bdb79adc614ceb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4486afd6c4..c9d9107ea5 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3659,7 +3659,7 @@ if there's more than one.")
(base32 "1xa6sgvnwynl2qrjnsppvb2vg4p5v1pisrfhrmnlymw1fzhh6s9p"))))
(build-system gnu-build-system)
(inputs
- (list libx11 perl perl-tk))
+ (list bash-minimal libx11 perl perl-tk))
(arguments
`(#:tests? #f ; There are none.
#:make-flags
@@ -3681,14 +3681,13 @@ if there's more than one.")
(lambda* (#:key outputs #:allow-other-keys)
(wrap-program (string-append (assoc-ref outputs "out")
"/bin/xkbset-gui")
- `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))
- #t))
+ `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))
(replace 'install-license-files
(lambda* (#:key outputs #:allow-other-keys)
(install-file "COPYRIGHT"
- (string-append (assoc-ref outputs "out")
- "/share/doc/" ,name "-" ,version))
- #t)))))
+ (string-append
+ (assoc-ref outputs "out")
+ "/share/doc/" ,name "-" ,version)))))))
(home-page "https://stephenmontgomerysmith.github.io/software/#xkbset")
(synopsis "User-preference utility for XKB extensions for X")
(description