path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-15 13:40:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-15 14:26:44 +0200
commita3370b30f7c784d84d42f6d20ae577e5a4955a33 (patch)
treee82ba994a436b545881cf36fca90de69b4079e0e /gnu
parent6e1aa1c443071ac8f37dc7d624a94d9c893009dd (diff)
downloadguix-a3370b30f7c784d84d42f6d20ae577e5a4955a33.tar.gz
guix-a3370b30f7c784d84d42f6d20ae577e5a4955a33.zip
gnu: volk: Make retained references non-native inputs.
* gnu/packages/engineering.scm (volk)[native-inputs]: Move python-wrapper and python-mako… [inputs]: …here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6edc79906c..6b776a175b 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1057,9 +1057,8 @@ the 'showing the effect of'-style of operation.")
(,(string-append python "/bin:")))))
#t)))))
(inputs
- `(("boost" ,boost)))
- (native-inputs
- `(("python" ,python-wrapper)
+ `(("boost" ,boost)
+ ("python" ,python-wrapper)
("python-mako" ,python-mako)))
(home-page "https://www.libvolk.org/")
(synopsis "Vector-Optimized Library of Kernels")
ocesses) #:use-module (guix scripts processes) #:use-module (guix store) #:use-module (guix derivations) #:use-module (guix packages) #:use-module (guix gexp) #:use-module ((guix utils) #:select (call-with-temporary-directory)) #:use-module (gnu packages bootstrap) #:use-module (guix tests) #:use-module (srfi srfi-1) #:use-module (srfi srfi-64) #:use-module (rnrs bytevectors) #:use-module (rnrs io ports) #:use-module (ice-9 match) #:use-module (ice-9 threads)) ;; When using --system argument, binfmt-misc mechanism may be used. In that ;; case, (guix script processes) won't work because: ;; ;; * ARGV0 is qemu-user and not guix-daemon. ;; * Guix-daemon won't be able to stuff client PID in ARGV1 of forked ;; processes. ;; ;; See: https://lists.gnu.org/archive/html/bug-guix/2019-12/msg00017.html. ;; ;; If we detect that we are running with binfmt emulation, all the following ;; tests must be skipped. (define (binfmt-misc?) (let ((pid (getpid)) (cmdline (call-with-input-file "/proc/self/cmdline" get-string-all))) (match (primitive-fork) (0 (dynamic-wind (const #t) (lambda () (exit (not (equal? (call-with-input-file (format #f "/proc/~a/cmdline" pid) get-string-all) cmdline)))) (const #t))) (x (zero? (cdr (waitpid x))))))) (define-syntax-rule (test-assert* description exp) (begin (when (binfmt-misc?) (test-skip 1)) (test-assert description exp))) (test-begin "processes") (test-assert* "not a client" (not (find (lambda (session) (= (getpid) (process-id (daemon-session-client session)))) (daemon-sessions)))) (test-assert* "client" (with-store store (let* ((session (find (lambda (session) (= (getpid) (process-id (daemon-session-client session)))) (daemon-sessions))) (daemon (daemon-session-process session))) (and (kill (process-id daemon) 0) (string-suffix? "guix-daemon" (first (process-command daemon))))))) (test-assert* "client + lock" (with-store store (call-with-temporary-directory (lambda (directory) (let* ((token1 (string-append directory "/token1")) (token2 (string-append directory "/token2")) (exp #~(begin #$(random-text) (mkdir #$token1) (let loop () (unless (file-exists? #$token2) (sleep 1) (loop))) (mkdir #$output))) (guile (package-derivation store %bootstrap-guile)) (drv (run-with-store store (gexp->derivation "foo" exp #:guile-for-build guile))) (thread (call-with-new-thread (lambda () (build-derivations store (list drv))))) (_ (let loop () (unless (file-exists? token1) (usleep 200) (loop)))) (session (find (lambda (session) (= (getpid) (process-id (daemon-session-client session)))) (daemon-sessions))) (locks (daemon-session-locks-held (pk 'session session)))) (call-with-output-file token2 (const #t)) (equal? (list (string-append (derivation->output-path drv) ".lock")) locks)))))) (test-end "processes")