aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-12-21 21:12:51 -0600
committerjgart <jgart@dismail.de>2024-12-21 21:34:24 -0600
commita332c23a691cf5d2a195c8e5d97d6036708f2e72 (patch)
treeedc794ea7063c900e2717b41755641db68ac6ca1 /gnu
parent982ef659b2175b8335d83cb15c499c5bc1dd21e2 (diff)
downloadguix-a332c23a691cf5d2a195c8e5d97d6036708f2e72.tar.gz
guix-a332c23a691cf5d2a195c8e5d97d6036708f2e72.zip
music: abjad-ext-ipython: Remove abjad-ext-ipython.
This package is no longer maintained nor supported for the current version of abjad that we package. See the issue below for more context. https://github.com/Abjad/abjad-ext-ipython/issues/9 * gnu/packages/music.scm (abjad-ext-ipython): Remove variable. Change-Id: Id77d340c403bc0619d8664b2a2be69cf3b197efc
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm53
1 files changed, 0 insertions, 53 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4c0d4d0c68..69f6de13fb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1878,59 +1878,6 @@ and manipulating rhythms such as accelerandi, taleas, and more.")
music theorist Paul Nauert's quantization grids or Q-Grids, for short.")
(license license:expat)))
-(define-public abjad-ext-ipython
- (package
- (name "abjad-ext-ipython")
- (version "3.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Abjad/abjad-ext-ipython")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1vv0alpiz0gf5lgjfvlh4km72dvrxfqkwzxl3k4amzci3i0jzbs2"))))
- (build-system python-build-system)
- (arguments
- ;; UnboundLocalError: local variable 'output_path' referenced before assignment
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'loosen-requirements
- (lambda _
- (substitute* "setup.py"
- ;; Don't require a specific version of abjad.
- (("abjad==")
- "abjad>="))))
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (setenv "HOME" (getcwd))
- (add-installed-pythonpath inputs outputs)
- ;; From 'make jupyter-test'
- (invoke "jupyter" "nbconvert" "--to=html"
- "--ExecutePreprocessor.enabled=True" "tests/test.ipynb")))))))
- (native-inputs
- (list lilypond
- python-black
- python-flake8
- python-iniconfig
- python-isort
- python-mypy
- python-pytest
- python-pytest-cov
- python-pytest-helpers-namespace))
- (propagated-inputs
- (list abjad jupyter python-sphinx-autodoc-typehints))
- (home-page "https://abjad.github.io")
- (synopsis "Abjad IPython Extension")
- (description
- "@code{abjad-ext-ipython} makes it possible to embed music notation in
-@code{jupyter} notebooks.")
- (license license:expat)))
-
(define-public non-sequencer
;; The latest tagged release is three years old and uses a custom build
;; system, so we take the last commit.