aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:19:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:35 +0200
commita1b56241da1d4a4fa7a132918f874f7a17daffda (patch)
treebd013679abe33dbeda654839f7db5eda8a909787 /gnu
parentb37e07414b53150417ff243fd87dd2357ee56e3e (diff)
downloadguix-a1b56241da1d4a4fa7a132918f874f7a17daffda.tar.gz
guix-a1b56241da1d4a4fa7a132918f874f7a17daffda.zip
gnu: Add texlive-pinlabel.
* gnu/packages/tex.scm (texlive-pinlabel): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 83cef56957..60bb9beba2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3340,6 +3340,27 @@ modifies @code{\\plot} to use a rule instead of dots if the line segment is
horizontal or vertical.")
(license license:lppl)))
+(define-public texlive-pinlabel
+ (package
+ (name "texlive-pinlabel")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pinlabel/" "tex/latex/pinlabel/")
+ (base32
+ "0hfa6gdmc6f59840fia3pdll2bgjwyqk57plcqxb4vc0f7kdqqay")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pinlabel")
+ (synopsis "TeX labelling package")
+ (description
+ "Pinlabel is a labelling package for attaching perfectly formatted TeX
+labels to figures and diagrams in both EPS and PDF formats. It is suitable
+both for labelling a new diagram and for relabelling an existing diagram. The
+package uses coordinates derived from GhostView and labels are placed with
+automatic and consistent spacing relative to the object labelled.")
+ (license license:lppl)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")