aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-10-06 22:41:15 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-06 23:17:04 +0200
commita0c83aa04bd45ee17ee72df529866ee4ac6041e3 (patch)
tree6651118ab20eef65442b2e71da3183e17ab9eff4 /gnu
parent96cbfc620263550002a897682e89b8dc0620d933 (diff)
downloadguix-a0c83aa04bd45ee17ee72df529866ee4ac6041e3.tar.gz
guix-a0c83aa04bd45ee17ee72df529866ee4ac6041e3.zip
gnu: python-textual: Remove input labels.
* gnu/packages/python-xyz.scm (python-textual)[arguments]: Define the 'tests' origin here. [native-inputs]: Remove "tests" input and remove input labels.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 823e5952e4..60870f5447 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16053,32 +16053,31 @@ syntax highlighting, markdown and more to the terminal.")
"08yg5a51hz1axfj5hx28hx31gq5apcj6vpkkmawmiplisa73z25j"))))
(build-system python-build-system)
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs tests? #:allow-other-keys)
- (when tests?
- (copy-recursively (string-append
- (assoc-ref inputs "tests") "/tests")
- "tests")
- (invoke "python" "-m" "pytest" "-vv")))))))
+ (let ((tests
+ ;; The release on pypi comes without tests. We can't build
+ ;; from this checkout, though, because installation requires
+ ;; an invocation of poetry.
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Textualize/textual")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b3ycwqhp21mg9fvmadgxhgbvkwq6fd784l2xcmvy77rravrnnax")))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (copy-recursively #$(file-append tests "/tests")
+ "tests")
+ (invoke "python" "-m" "pytest" "-vv"))))))))
(propagated-inputs
(list python-rich python-typing-extensions))
(native-inputs
- `(("python-pytest" ,python-pytest)
- ("tests"
- ;; The release on pypi comes without tests. We can't build from this
- ;; checkout, though, because installation requires an invocation of
- ;; poetry.
- ,(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Textualize/textual")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0b3ycwqhp21mg9fvmadgxhgbvkwq6fd784l2xcmvy77rravrnnax"))))))
+ (list python-pytest))
(home-page "https://github.com/Textualize/textual")
(synopsis "Build text user interfaces in Python")
(description "Textual is a @acronym{TUI, Text User Interface} framework