aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-11-01 13:20:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-04 11:22:54 +0100
commit9ff01f2d018d65f01b1a6a66bd28c26f196719bc (patch)
tree9d99c061337ef2cba27a2c5f39e7861b426978ca /gnu
parent4263b06fa2bf3e25ec21fa39822b548fc3a6e8ca (diff)
downloadguix-9ff01f2d018d65f01b1a6a66bd28c26f196719bc.tar.gz
guix-9ff01f2d018d65f01b1a6a66bd28c26f196719bc.zip
gnu: Add python-jupyter-client.
* gnu/packages/python.scm (python-jupyter-client, python2-jupyter-client): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index da16647c2d..0f1697820d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4525,6 +4525,38 @@ without using the configuration machinery.")
(define-public python2-jupyter-core
(package-with-python2 python-jupyter-core))
+(define-public python-jupyter-client
+ (package
+ (name "python-jupyter-client")
+ (version "4.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter_client" version))
+ (sha256
+ (base32
+ "1vjjrpjw7k5sh982pbjnslv7byfbfazjw9g92jvs7dz5qbx556n9"))))
+ (build-system python-build-system)
+ ;; Tests fail because of missing native python kernel which I assume is
+ ;; provided by the ipython package, which we cannot use because it would
+ ;; cause a dependency cycle.
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("python-pyzmq" ,python-pyzmq)
+ ("python-traitlets" ,python-traitlets)
+ ("python-jupyter-core" ,python-jupyter-core)))
+ (home-page "http://jupyter.org/")
+ (synopsis "Jupyter protocol implementation and client libraries")
+ (description
+ "The @code{jupyter_client} package contains the reference implementation
+of the Jupyter protocol. It also provides client and kernel management APIs
+for working with kernels, and the @code{jupyter kernelspec} entrypoint for
+installing @code{kernelspec}s for use with Jupyter frontends.")
+ (license license:bsd-3)))
+
+(define-public python2-jupyter-client
+ (package-with-python2 python-jupyter-client))
+
(define-public python-ipython
(package
(name "python-ipython")
ck (lambda _ ;; install temporarily into /tmp/netpbm (invoke "make" "package") ;; remove test requiring X (substitute* "test/all-in-place.test" (("pamx") "")) ;; do not worry about non-existing file (substitute* "test/all-in-place.test" (("^rm ") "rm -f ")) ;; remove four tests that fail for unknown reasons (substitute* "test/Test-Order" (("all-in-place.test") "") (("pnmpsnr.test") "") (("pnmremap1.test") "") (("gif-roundtrip.test") "") ;; These two tests fail on powerpc-linux. ,@(if (target-ppc32?) `((("pbmtog3\\.test") "") (("g3-roundtrip\\.test") "")) '()) ;; These two tests started failing in netpbm-10.78.3. (("jpeg-roundtrip.test") "") (("pbmtext.test") "") ;; Skip tests that use nonfree programs that we don't build. (("ps-alt-roundtrip.test") "" ) (("pbm-misc-converters.test") "")) #t)) (replace 'install (lambda* (#:key outputs make-flags #:allow-other-keys) (let ((out (assoc-ref outputs "out"))) (apply invoke "make" "package" (string-append "pkgdir=" out) make-flags) ;; Remove superfluous files. (with-directory-excursion out (for-each delete-file-recursively '("config_template" "pkginfo" "README" "VERSION" "link/" "misc/")) ;; Install the required ‘libnetpbm.so’ link. ;; See <https://issues.guix.gnu.org/issue/40376>. (with-directory-excursion "lib" (symlink (match (find-files "." "^libnetpbm\\.so\\.[^.]*\\.[^.]*$") ((head _ ...) head)) "libnetpbm.so")) #t))))))) (synopsis "Toolkit for manipulation of images") (description "Netpbm is a toolkit for the manipulation of graphic images, including the conversion of images between a variety of different formats. There are over 300 separate tools in the package including converters for about 100 graphics formats.") (license gpl2) (home-page "https://netpbm.sourceforge.net/")))