aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-17 00:44:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:22 +0200
commit9f6188727b4f6e3a462a3456e996555dce243ab5 (patch)
treef414f90d04981bbb652a99f51ab3c9d8546ef449 /gnu
parent12dcf8f384f7ca78251cc8714ce734b06548469b (diff)
downloadguix-9f6188727b4f6e3a462a3456e996555dce243ab5.tar.gz
guix-9f6188727b4f6e3a462a3456e996555dce243ab5.zip
gnu: texlive-fontname: Refresh package definition.
* gnu/packages/tex.sfontname (texlive-fontname): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8a454cfa6a..f632266a10 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1102,20 +1102,23 @@ typesetting in these fonts.")
(define-public texlive-fontname
(package
- (inherit (simple-texlive-package
- "texlive-fontname"
- (list "/doc/fonts/fontname/fontname.texi"
- "/fonts/map/fontname/")
- (base32
- "009qvjpw48lajp0gxpvdk10n5qw3q41cpq05ycns67mxwkcaywq6")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/fontname")
+ (name "texlive-fontname")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/fontname/" "doc/info/fontname.info"
+ "fonts/map/fontname/")
+ (base32
+ "014kiwbqz77yn8w58cb6fzqj0vlfmgyq09mxdj15ipjfgxjyvcbj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/fontname")
(synopsis "Scheme for naming fonts in TeX")
- (description "This is Fontname, a naming scheme for (the base part of)
-external TeX font filenames. This makes at most eight-character names
-from (almost) arbitrarily complex font names, thus helping portability of TeX
-documents.")
- (license license:public-domain)))
+ (description
+ "This is Fontname, a naming scheme for (the base part of) external TeX
+font filenames. This makes at most eight-character names from (almost)
+arbitrarily complex font names, thus helping portability of TeX documents.")
+ (license license:gpl3+)))
(define-public texlive-cbfonts ;71 MiB of greek fonts
(package