aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-03-15 23:12:32 +0100
committerMark H Weaver <mhw@netris.org>2015-03-21 20:24:31 -0400
commit9d297fae5f42300909d0a9b8031c14f4c332ed9e (patch)
tree102a5c05a3c9753ae4b84bfdc29c457da08b3956 /gnu
parent3c76a81b94d4f8f932fa94d2761b22d05cf8ae4f (diff)
downloadguix-9d297fae5f42300909d0a9b8031c14f4c332ed9e.tar.gz
guix-9d297fae5f42300909d0a9b8031c14f4c332ed9e.zip
gnu: gtk+-2: build gobject introspection typelib file.
* gnu/packages/gtk.scm (gtk+-2): add `gobject-introspection' to the native-inputs to install typelib file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index fef5a814db..b3688d5ec1 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -408,10 +408,12 @@ is part of the GNOME accessibility project.")
(native-inputs
`(("perl" ,perl)
("glib" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
(arguments
- `(#:phases
+ `(#:make-flags '("CC=gcc")
+ #:phases
(alist-cons-before
'configure 'disable-tests
(lambda _