aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-05-14 16:23:55 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-14 16:53:11 +0200
commit9bb89b640ac37a1fdee927f7c3376eb6f0746cb5 (patch)
treea78c58d0ee11a8850e6cc9181b04b655132fbb28 /gnu
parent16ad755f94597cc47725a030ef1a65f94d4155c8 (diff)
downloadguix-9bb89b640ac37a1fdee927f7c3376eb6f0746cb5.tar.gz
guix-9bb89b640ac37a1fdee927f7c3376eb6f0746cb5.zip
gnu: gnuradio-osmosdr: Fix Python tools.
* gnu/packages/radio.scm (gnuradio-osmosdr)[native-inputs]: Move python to ... [inputs]: ... here. Add python-numpy and python-pyqt. [arguments]: Add Python wrapping phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/radio.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index c0898657a5..f25c097bbc 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -497,7 +497,6 @@ environment.")
`(("doxygen" ,doxygen)
("pkg-config" ,pkg-config)
("pybind11" ,pybind11)
- ("python" ,python)
("python-mako" ,python-mako)
("python-six" ,python-six)))
(inputs
@@ -509,8 +508,21 @@ environment.")
("hackrf" ,hackrf)
("libsndfile" ,libsndfile)
("log4cpp" ,log4cpp)
+ ("python" ,python)
+ ("python-numpy" ,python-numpy)
+ ("python-pyqt" ,python-pyqt)
("rtl-sdr" ,rtl-sdr)
("volk" ,volk)))
+ (arguments
+ `(#:modules ((guix build cmake-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build utils))
+ #:imported-modules (,@%cmake-build-system-modules
+ (guix build python-build-system))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-python
+ (assoc-ref python:%standard-phases 'wrap)))))
(synopsis "GNU Radio block for interfacing with various radio hardware")
(description "This is a block for GNU Radio allowing to use a common API
to access different radio hardware.")
u-boot (stat:size (stat u-boot)) image (* 16384 512))))) (define install-rockpro64-rk3399-u-boot #~(lambda (bootloader root-index image) (let ((idb (string-append bootloader "/libexec/idbloader.img")) (u-boot (string-append bootloader "/libexec/u-boot.itb"))) (write-file-on-device idb (stat:size (stat idb)) image (* 64 512)) (write-file-on-device u-boot (stat:size (stat u-boot)) image (* 16384 512))))) (define install-pinebook-pro-rk3399-u-boot install-rockpro64-rk3399-u-boot) (define install-u-boot-ts7970-q-2g-1000mhz-c-u-boot #~(lambda (bootloader device mount-point) (let ((u-boot.imx (string-append bootloader "/libexec/u-boot.imx")) (install-dir (string-append mount-point "/boot"))) (install-file u-boot.imx install-dir)))) (define install-sifive-unmatched-u-boot #~(lambda (bootloader root-index image) (let ((spl (string-append bootloader "/libexec/spl/u-boot-spl.bin")) (u-boot (string-append bootloader "/libexec/u-boot.itb"))) (write-file-on-device spl (stat:size (stat spl)) image (* 34 512)) (write-file-on-device u-boot (stat:size (stat u-boot)) image (* 2082 512))))) (define install-starfive-visionfive2-u-boot #~(lambda (bootloader root-index image) (let ((spl (string-append bootloader "/libexec/spl/u-boot-spl.bin.normal.out")) (u-boot (string-append bootloader "/libexec/u-boot.itb"))) (write-file-on-device spl (stat:size (stat spl)) image (* 34 512)) (write-file-on-device u-boot (stat:size (stat u-boot)) image (* 2082 512))))) (define install-starfive-visionfive2-uEnv.txt #~(lambda (bootloader device mount-point) (mkdir-p (string-append mount-point "/boot")) (call-with-output-file (string-append mount-point "/boot/uEnv.txt") (lambda (port) (format port ;; if board SPI use vender's u-boot, will find ;; ""starfive/starfive_visionfive2.dtb"", We cannot guarantee ;; that users will update this u-boot, so set it. "fdtfile=starfive/jh7110-starfive-visionfive-2-v1.3b.dtb~%"))))) (define install-qemu-riscv64-u-boot #~(lambda (bootloader device mount-point) (let ((u-boot.bin (string-append bootloader "/libexec/u-boot.bin")) (install-dir (string-append mount-point "/boot"))) (install-file u-boot.bin install-dir)))) ;;; ;;; Bootloader definitions. ;;; (define u-boot-bootloader (bootloader (inherit extlinux-bootloader) (name 'u-boot) (package #f) (installer #f) (disk-image-installer install-u-boot))) (define u-boot-beaglebone-black-bootloader (bootloader (inherit u-boot-bootloader) (package u-boot-am335x-boneblack) (disk-image-installer install-beaglebone-black-u-boot))) (define u-boot-allwinner-bootloader (bootloader (inherit u-boot-bootloader) (disk-image-installer install-allwinner-u-boot))) (define u-boot-allwinner64-bootloader (bootloader (inherit u-boot-bootloader) (disk-image-installer install-allwinner64-u-boot))) (define u-boot-imx-bootloader (bootloader (inherit u-boot-bootloader) (disk-image-installer install-imx-u-boot))) (define u-boot-nintendo-nes-classic-edition-bootloader (bootloader (inherit u-boot-allwinner-bootloader) (package u-boot-nintendo-nes-classic-edition))) (define u-boot-a20-olinuxino-lime-bootloader (bootloader (inherit u-boot-allwinner-bootloader) (package u-boot-a20-olinuxino-lime))) (define u-boot-a20-olinuxino-lime2-bootloader (bootloader (inherit u-boot-allwinner-bootloader) (package u-boot-a20-olinuxino-lime2))) (define u-boot-a20-olinuxino-micro-bootloader (bootloader (inherit u-boot-allwinner-bootloader) (package u-boot-a20-olinuxino-micro))) (define u-boot-bananapi-m2-ultra-bootloader (bootloader (inherit u-boot-allwinner-bootloader) (package u-boot-bananapi-m2-ultra))) (define u-boot-cubietruck-bootloader (bootloader (inherit u-boot-allwinner-bootloader) (package u-boot-cubietruck))) (define u-boot-firefly-rk3399-bootloader ;; SD and eMMC use the same format (bootloader (inherit u-boot-bootloader) (package u-boot-firefly-rk3399) (disk-image-installer install-firefly-rk3399-u-boot))) (define u-boot-mx6cuboxi-bootloader (bootloader (inherit u-boot-imx-bootloader) (package u-boot-mx6cuboxi))) (define u-boot-wandboard-bootloader (bootloader (inherit u-boot-imx-bootloader) (package u-boot-wandboard))) (define u-boot-novena-bootloader (bootloader (inherit u-boot-imx-bootloader) (package u-boot-novena))) (define u-boot-orangepi-r1-plus-lts-rk3328-bootloader (bootloader (inherit u-boot-bootloader) (package u-boot-orangepi-r1-plus-lts-rk3328) (disk-image-installer install-orangepi-r1-plus-lts-rk3328-u-boot))) (define u-boot-pine64-plus-bootloader (bootloader (inherit u-boot-allwinner64-bootloader) (package u-boot-pine64-plus))) (define u-boot-pine64-lts-bootloader (bootloader (inherit u-boot-allwinner-bootloader) (package u-boot-pine64-lts))) (define u-boot-pinebook-bootloader (bootloader (inherit u-boot-allwinner64-bootloader) (package u-boot-pinebook))) (define u-boot-puma-rk3399-bootloader (bootloader (inherit u-boot-bootloader) (package u-boot-puma-rk3399) (disk-image-installer install-puma-rk3399-u-boot))) (define u-boot-rock64-rk3328-bootloader ;; SD and eMMC use the same format (bootloader (inherit u-boot-bootloader) (package u-boot-rock64-rk3328) (disk-image-installer install-rock64-rk3328-u-boot))) (define u-boot-rockpro64-rk3399-bootloader ;; SD and eMMC use the same format (bootloader (inherit u-boot-bootloader) (package u-boot-rockpro64-rk3399) (disk-image-installer install-rockpro64-rk3399-u-boot))) (define u-boot-pinebook-pro-rk3399-bootloader ;; SD and eMMC use the same format (bootloader (inherit u-boot-bootloader) (package u-boot-pinebook-pro-rk3399) (disk-image-installer install-pinebook-pro-rk3399-u-boot))) (define u-boot-ts7970-q-2g-1000mhz-c-bootloader ;; This bootloader doesn't really need to be installed, as it is read from ;; an SPI memory chip, not the SD card. It is copied to /boot/u-boot.imx ;; for convenience and should be manually flashed at the U-Boot prompt. (bootloader (inherit u-boot-bootloader) (package u-boot-ts7970-q-2g-1000mhz-c) (installer install-u-boot-ts7970-q-2g-1000mhz-c-u-boot) (disk-image-installer #f))) (define u-boot-sifive-unmatched-bootloader (bootloader (inherit u-boot-bootloader) (package u-boot-sifive-unmatched) (disk-image-installer install-sifive-unmatched-u-boot))) (define u-boot-starfive-visionfive2-bootloader (bootloader (inherit u-boot-bootloader) (package u-boot-starfive-visionfive2) (installer install-starfive-visionfive2-uEnv.txt) (disk-image-installer install-starfive-visionfive2-u-boot))) (define u-boot-qemu-riscv64-bootloader (bootloader (inherit u-boot-bootloader) (package u-boot-qemu-riscv64) (installer install-qemu-riscv64-u-boot) (disk-image-installer #f)))