aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commit9bab4f41248985885cff252fe8eb7cb4771bb237 (patch)
treebd5ea3f6c659c217c5629972dfef6dec629a8840 /gnu
parentc13609005eeaa6502d868f4cdb3e51e49eda4577 (diff)
downloadguix-9bab4f41248985885cff252fe8eb7cb4771bb237.tar.gz
guix-9bab4f41248985885cff252fe8eb7cb4771bb237.zip
gnu: Add ghc-crypton-x509-validation.
* gnu/packages/haskell-crypto.scm (ghc-crypton-x509-validation): New variable. Change-Id: Ib25c2dee8fef24c763cf70dfa1c615405d250d39
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-crypto.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index ce59f0a23c..0198c57272 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -722,6 +722,34 @@ lists.")
storage methods, and accessors.")
(license license:bsd-3)))
+(define-public ghc-crypton-x509-validation
+ (package
+ (name "ghc-crypton-x509-validation")
+ (version "1.6.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "crypton-x509-validation" version))
+ (sha256
+ (base32 "1xjhwvmkcy47a6xiqxb3xy944ca7g660203jdrz5xzd46zibfq0f"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "crypton-x509-validation")))
+ (inputs (list ghc-memory
+ ghc-hourglass
+ ghc-data-default-class
+ ghc-pem
+ ghc-asn1-types
+ ghc-asn1-encoding
+ ghc-crypton-x509
+ ghc-crypton-x509-store
+ ghc-crypton))
+ (native-inputs (list ghc-tasty ghc-tasty-hunit))
+ (home-page "https://github.com/kazu-yamamoto/crypton-certificate")
+ (synopsis "X.509 Certificate and CRL validation")
+ (description "This package provides Haskell tools for X.509 certificate
+and @dfn{Certificates revocation list} (CRL) validation.")
+ (license license:bsd-3)))
+
(define-public ghc-cprng-aes
(package
(name "ghc-cprng-aes")