aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-17 11:26:53 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:24 +0000
commit9b8cbb544d4a92b949337ae4d26ec3f22dda6237 (patch)
treec57558757f5e1c52b520e30a3a779d258895bb24 /gnu
parent1da372e3c2f0d52863975161af561670422d86b2 (diff)
downloadguix-9b8cbb544d4a92b949337ae4d26ec3f22dda6237.tar.gz
guix-9b8cbb544d4a92b949337ae4d26ec3f22dda6237.zip
gnu: python-matplotlib: Disable more failing tests.
* gnu/packages/python-xyz.scm (python-matplotlib): 5 more tests are disabled, they fail with verity of warnings and look save to silent. Change-Id: I81693452aa88ddbd44fb615f4d4251b5309e4ebe
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 23 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9c53e32431..b0ea1b4cfc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9727,14 +9727,29 @@ comparison.
(list
#:test-flags
'(list "-m" "not network"
- "-k"
- (string-append
- ;; This one fails with a small difference in the upper left.
- "not test_figure_legend_outside"
- " and not test_warn_big_data_best_loc"
- ;; The 'test_lazy_auto_backend_selection' fails
- ;; because it would require an X server; skip it.
- " and not test_lazy_auto_backend_selection"))
+ "-k" (string-join
+ (list
+ ;; This one fails with a small difference in the upper left.
+ "not test_figure_legend_outside"
+ "test_warn_big_data_best_loc"
+ ;; The 'test_lazy_auto_backend_selection' fails because it
+ ;; would require an X server; skip it.
+ "test_lazy_auto_backend_selection"
+ ;; It fails with deprecation warning The register_cmap function
+ ;; was deprecated in Matplotlib 3.7 and will be removed two
+ ;; minor releases later.
+ "test_double_register_builtin_cmap"
+ ;; Failed: DID NOT WARN. No warnings of type (<class
+ ;; 'UserWarning'>,) were emitted.
+ "test_rcparams_update"
+ "test_rcparams_init"
+ ;; ResourceWarning: unclosed file <_io.BufferedWriter
+ ;; name='a.pdf'>
+ "test_multipage_keep_empty"
+ ;; UserWarning: Glyph 8722 (\N{MINUS SIGN}) missing from
+ ;; current font.
+ "test_mathtext_ticks")
+ " and not "))
#:phases
#~(modify-phases %standard-phases
(add-before 'build 'pretend-version