aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 21:43:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 21:43:31 +0100
commit9b4b9bd92889bc89c7a7c7ba4559f2c4e966f778 (patch)
tree2a4b61b237f1fd8b4e49dd23f920e43385548fd7 /gnu
parent0a46e960d0a91a22853a7ad9b24422d07bc12a8c (diff)
downloadguix-9b4b9bd92889bc89c7a7c7ba4559f2c4e966f778.tar.gz
guix-9b4b9bd92889bc89c7a7c7ba4559f2c4e966f778.zip
gnu: Add go-github-com-go-logr-stdr.
* gnu/packages/golang-xyz.scm (go-github-com-go-logr-stdr): New variable. Change-Id: I3cbe5e34306ee0c07143155e499f9f0aa6be2761
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 09e45175a6..becdef319b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2638,6 +2638,33 @@ interfaces to back that API. Packages in the Go ecosystem can depend on it,
while callers can implement logging with whatever backend is appropriate.")
(license license:asl2.0)))
+(define-public go-github-com-go-logr-stdr
+ (package
+ (name "go-github-com-go-logr-stdr")
+ (version "1.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-logr/stdr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dl2rzvjacwqlnvw7azrxqbh4jvzaq8v399f6drs146l39ss21c1"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no tests for stdr.go
+ #:import-path "github.com/go-logr/stdr"))
+ (propagated-inputs
+ (list go-github-com-go-logr-logr))
+ (home-page "https://github.com/go-logr/stdr")
+ (synopsis "Minimal Go logging using logr and Go's standard library")
+ (description
+ "Package stdr implements github.com/go-logr/logr.Logger in terms of Go's
+standard log package.")
+ (license license:asl2.0)))
+
(define-public go-github-com-go-playground-locales
(package
(name "go-github-com-go-playground-locales")