aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2024-10-26 00:19:10 +0000
committerLudovic Courtès <ludo@gnu.org>2024-12-18 13:22:47 +0100
commit9a7899738ac95866844c938d612a0e1e87da3cf2 (patch)
treef441d105376e164e8332be43363f602ebc3e3e5a /gnu
parente25b491d5e3a6f03527a33c5b74d872b70c0d6f4 (diff)
downloadguix-9a7899738ac95866844c938d612a0e1e87da3cf2.tar.gz
guix-9a7899738ac95866844c938d612a0e1e87da3cf2.zip
gnu: Add julia-simdtypes.
* gnu/packages/julia-xyz.scm (julia-simdtypes): New variable. Change-Id: I33f4321abd19b44bc0d04dac45be07624ad55098 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 4443429e30..1cd4868d67 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5842,6 +5842,26 @@ whether it is beneficial to do so, and rearranging the code to synthesize
vector instructions.")
(license license:expat)))
+(define-public julia-simdtypes
+ (package
+ (name "julia-simdtypes")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaSIMD/SIMDTypes.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qkg0rwfq0q746j2k5wg3dvrcmxm3lfxw0mxqrqdxccnjnmgcbkr"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaSIMD/SIMDTypes.jl")
+ (synopsis "SIMD type declarations")
+ (description "This minimalistic package serves as the foundation for
+other SIMD packages in Julia.")
+ (license license:expat)))
+
(define-public julia-simpletraits
(package
(name "julia-simpletraits")