aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-05-24 12:16:56 -0400
committerLeo Famulari <leo@famulari.name>2021-05-24 13:51:48 -0400
commit9a57cac2a09aa592b29eaba8738c32a585efd82c (patch)
treefc872fc21aa0fadfa4443467be8e8ea7f1ff52c4 /gnu
parent2fca4acdf6942ce9fbaf3580dda4e5fa7cabd2f2 (diff)
downloadguix-9a57cac2a09aa592b29eaba8738c32a585efd82c.tar.gz
guix-9a57cac2a09aa592b29eaba8738c32a585efd82c.zip
gnu: linux-libre 4.14: Update to 4.14.233.
* gnu/packages/linux.scm (linux-libre-4.14-version): Update to 4.14.233. (linux-libre-4.14-pristine-source): Update hash. (deblob-scripts-4.14): Update hash.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 66e1daf38c..f5e2a4b1fc 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -411,15 +411,15 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-4.19)))
-(define-public linux-libre-4.14-version "4.14.232")
+(define-public linux-libre-4.14-version "4.14.233")
(define deblob-scripts-4.14
(linux-libre-deblob-scripts
linux-libre-4.14-version
- (base32 "091jk9jkn9jf39bxpc7395bhcb7p96nkg3a8047380ki06lnfxh6")
+ (base32 "07afckszdm4pq008i6ij0pxpw2rpgi5q931nxh6dxcczpicvwbc9")
(base32 "1qij18inijj6c3ma8hv98yjagnzxdxyn134da9fd23ky8q6hbvky")))
(define-public linux-libre-4.14-pristine-source
(let ((version linux-libre-4.14-version)
- (hash (base32 "0sa3sz7bznlhijd0iwv37nyrrnw34iq6dq1bqr6cj2wpyrhr7h8x")))
+ (hash (base32 "0sqikz8cvrjfs46mcqx9gbdfkpdims0m5xxxzwr5vcfph5rdvj26")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.14)))
an>guix-register: Support registration in the current store, without '--prefix'....* nix/guix-register/guix-register.cc (register_validity): Leave 'info.path' unmodified when PREFIX is empty. (main): Call 'settings.processEnvironment' early on. Leave 'settings.nixStore' unmodified when PREFIX is empty. Ludovic Courtès 2013-09-23guix-register: Expect closures to refer to the original store....* nix/guix-register/guix-register.cc (prefix): New variable. (parse_opt): Use it. (register_validity): Change 'info.path' to the final store name. Hash the final under its real path. * tests/guix-register.sh: Adjust the contents of $closure accordingly. Rename 'NIX_LOCALSTATE_DIR' to 'NIX_STATE_DIR'. Don't try to call 'valid-path?'. Add test using 'sqlite3'. Ludovic Courtès 2013-09-23Add 'guix-register'....* nix/guix-register/guix-register.cc, tests/guix-register.sh: New files. * Makefile.am (SH_TESTS)[BUILD_DAEMON]: Add tests/guix-register.sh. * daemon.am (sbin_PROGRAMS, guix_register_SOURCES, guix_register_CPPFLAGS, guix_register_LDADD): New variables. * test-env.in: Export 'storedir', 'prefix', 'datarootdir', 'datadir', and 'localstatedir'. Ludovic Courtès