aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-16 23:20:26 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:24 +0000
commit978334062ca41025609d4bcf81b06e22906fcb77 (patch)
tree507c42e9485c6bdc585a786d16aee2fadacd7f2c /gnu
parent5643b69d52998027519d0c87331c9bd6c20825bf (diff)
downloadguix-978334062ca41025609d4bcf81b06e22906fcb77.tar.gz
guix-978334062ca41025609d4bcf81b06e22906fcb77.zip
gnu: Add python-ephemeral-port-reserve.
* gnu/packages/python-web.scm (python-ephemeral-port-reserve): New variable. Change-Id: I198370d0d3b6ddaf3cc94a98a2cbebb654072e53
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index efa2e3e14b..b72f88a68d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5401,6 +5401,27 @@ this it tries to be opinion-free and very extendable.")
server.")
(license license:expat)))
+(define-public python-ephemeral-port-reserve
+ (package
+ (name "python-ephemeral-port-reserve")
+ (version "1.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ephemeral_port_reserve" version))
+ (sha256
+ (base32 "1chl9hil7ggz6l4sfhmp0l2j55qcskbc3pj9360b0309jwndmxxq"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (home-page "https://github.com/Yelp/ephemeral-port-reserve/")
+ (synopsis "Find an unused port, reliably")
+ (description
+ "Bind to an ephemeral port, force it into the TIME_WAIT state, and unbind
+it.")
+ (license license:expat)))
+
(define-public python-flask-migrate
(package
(name "python-flask-migrate")