aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 10:44:09 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:05 +0800
commit975ae462242ac448e2a2853455b38ea4ff89b988 (patch)
tree9331c15badca56aa46edd897a9e22577723d71cb /gnu
parent8be05dd7d7d7e34d6bb4c383fe311d24d1726e9b (diff)
downloadguix-975ae462242ac448e2a2853455b38ea4ff89b988.tar.gz
guix-975ae462242ac448e2a2853455b38ea4ff89b988.zip
gnu: kdeclarative: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (kdeclarative): Update to 6.3.0. [inputs]: Remove kauth, kcoreaddons, kiconthemes, kio, kjobwidgets, knotifications, kservice, kwindowsystem, libepoxy, qtbase-5, qtdeclarative-5, and solid; add qtshadertools and qtbase. [propagated-inputs]: Remove kpackage and qtdeclarative-5; add qtdeclarative. [native-inputs]: Remove dbus, pkg-config, and xorg-server-for-tests. [arguments]: Remove it. Change-Id: I547ecc9f01380d5ed9c8d1422af29fcc8b4ea480
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm43
1 files changed, 7 insertions, 36 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 40bccf0199..3a764a6bf1 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2440,7 +2440,7 @@ their settings.")
(define-public kdeclarative
(package
(name "kdeclarative")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2449,48 +2449,19 @@ their settings.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0w98pj8acxb4m9645963rzq5vja1fbih5czz24mf9zdqlg2dkz8g"))))
+ "1kkdlkavd3v60sihxvlqxw2fmv1szf04llffhm0db7kmhz286zc0"))))
(build-system cmake-build-system)
(propagated-inputs
- (list kconfig kpackage qtdeclarative-5))
+ (list kconfig qtdeclarative))
(native-inputs
- (list dbus extra-cmake-modules pkg-config xorg-server-for-tests))
+ (list extra-cmake-modules))
(inputs
- (list kauth
- kcoreaddons
- kglobalaccel
+ (list kglobalaccel
kguiaddons
- kiconthemes
- kio
ki18n
- kjobwidgets
- knotifications
- kservice
kwidgetsaddons
- kwindowsystem
- libepoxy
- qtbase-5
- qtdeclarative-5
- solid))
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-before 'check 'start-xorg-server
- (lambda* (#:key inputs #:allow-other-keys)
- ;; The test suite requires a running X server, setting
- ;; QT_QPA_PLATFORM=offscreen does not suffice.
- (system "Xvfb :1 -screen 0 640x480x24 &")
- (setenv "DISPLAY" ":1")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "HOME"
- (getcwd))
- (setenv "XDG_RUNTIME_DIR"
- (getcwd))
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (invoke "dbus-launch" "ctest")))))))
+ qtshadertools
+ qtbase))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Integration of QML and KDE work spaces")
(description "KDeclarative provides integration of QML and KDE work spaces.