aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-08-10 00:45:55 -0500
committerjgart <jgart@dismail.de>2024-08-10 00:45:55 -0500
commit966afbc375aa7eadf3f9ef0a66ffad35da93721f (patch)
tree8ee17fe055656c6269501f7bea6b9deb023495da /gnu
parente58d5e1dbacf8e32fdc5687bf7cb5e35fa3fccac (diff)
downloadguix-966afbc375aa7eadf3f9ef0a66ffad35da93721f.tar.gz
guix-966afbc375aa7eadf3f9ef0a66ffad35da93721f.zip
gnu: python-base58: Move to pyproject-build-system.
* gnu/packages/python-crypto.scm (python-base58): Move to pyproject-build-system. [build-system]: Use pyproject-build-system. [arguments]: Convert to use the modern gexp style. Change-Id: If95dbaa274b5c430441215a21168ea30808157a9
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-crypto.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index ffafee7dd6..86a826b7ed 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2023 Juliana Sims <juli@incana.org>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -90,12 +91,14 @@
(sha256
(base32
"1317ly0db7nnjg5k58f6nqa0svfcvn446xd5bpiyi0bfbczwpl65"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests? (invoke "pytest" "-vv")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "pytest" "-vv")))))))
(native-inputs
(list python-pyhamcrest python-pytest python-pytest-benchmark))
(home-page "https://github.com/keis/base58")