aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 11:57:04 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:32 +0200
commit9631bd6d3085a32fb80b6bc82a8b423928608d70 (patch)
tree0f5a9d124ba119cfef3104c2227717cea6133fda /gnu
parent24f57dadc7a38653064eb9a9cd4020abf6c2e033 (diff)
downloadguix-9631bd6d3085a32fb80b6bc82a8b423928608d70.tar.gz
guix-9631bd6d3085a32fb80b6bc82a8b423928608d70.zip
gnu: pciutils: Update to 3.8.0.
* gnu/packages/pciutils.scm (pciutils): Update to 3.8.0. [source](patches): Remove. [arguments]: Don't apply patch. Add CC in #:make-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/patches/pciutils-hurd-configure.patch35
-rw-r--r--gnu/packages/patches/pciutils-hurd-fix.patch23
-rw-r--r--gnu/packages/pciutils.scm25
4 files changed, 9 insertions, 76 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 435727879a..9d76963545 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1578,8 +1578,6 @@ dist_patch_DATA = \
%D%/packages/patches/pam-krb5-CVE-2020-10595.patch \
%D%/packages/patches/pango-skip-libthai-test.patch \
%D%/packages/patches/password-store-tree-compat.patch \
- %D%/packages/patches/pciutils-hurd-configure.patch \
- %D%/packages/patches/pciutils-hurd-fix.patch \
%D%/packages/patches/pitivi-fix-build-with-meson-0.60.patch \
%D%/packages/patches/pjproject-install-libpjsua2.patch \
%D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
diff --git a/gnu/packages/patches/pciutils-hurd-configure.patch b/gnu/packages/patches/pciutils-hurd-configure.patch
deleted file mode 100644
index 226891a995..0000000000
--- a/gnu/packages/patches/pciutils-hurd-configure.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Add ability to detect GNU/Hurd when configuring.
-
-Adapted from https://git.hadrons.org/cgit/debian/pkgs/pciutils.git/tree/debian/patches/00-configure-hurd.patch
-
-From e39a3af22501234a91cf28e8c57b45f9379f9101 Mon Sep 17 00:00:00 2001
-From: Damien Zammit <damien@zamaudio.com>
-Date: Fri, 26 Oct 2018 09:24:04 -0400
-Subject: [PATCH 2/2] Add ability to detect GNU/Hurd when configuring
-
----
- lib/configure | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
---- a/lib/configure
-+++ b/lib/configure
-@@ -25,7 +25,7 @@ if [ -z "$HOST" ] ; then
- proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1`
- cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'`
- else
-- cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
-+ cpu=`uname -m | sed 's/^i.86-AT386/i386/;s/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
- fi
- if [ "$sys" = "DragonFly" ]
- then
-@@ -39,6 +39,10 @@ if [ -z "$HOST" ] ; then
- then
- sys=cygwin
- fi
-+ if [ "$sys" = "GNU" ]
-+ then
-+ sys=gnu
-+ fi
- HOST=${3:-$cpu-$sys}
- fi
- [ -n "$RELEASE" ] && rel="${RELEASE}"
diff --git a/gnu/packages/patches/pciutils-hurd-fix.patch b/gnu/packages/patches/pciutils-hurd-fix.patch
deleted file mode 100644
index f1979d4352..0000000000
--- a/gnu/packages/patches/pciutils-hurd-fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Fix a build error on GNU/Hurd for pciutils 3.7.0.
-
-commit 053cf6c8b2acafadf828912828336d90fe9b8696
-Author: Martin Mares <mj@ucw.cz>
-Date: Sun May 31 11:53:28 2020 +0200
-
- HURD backend should compile again
-
- Fixes a bug introduced by commit 82c06b47dea5a38075ce9d56f743360bc47b4c78.
-
-diff --git a/lib/hurd.c b/lib/hurd.c
-index 7b3b2ae..ccd92f6 100644
---- a/lib/hurd.c
-+++ b/lib/hurd.c
-@@ -307,7 +307,6 @@ hurd_fill_regions(struct pci_dev *d)
- d->base_addr[i] |= regions[i].is_64 << 2;
- d->base_addr[i] |= regions[i].is_prefetchable << 3;
-
-- if (flags & PCI_FILL_SIZES)
-- d->size[i] = regions[i].size;
-+ d->size[i] = regions[i].size;
- }
- }
diff --git a/gnu/packages/pciutils.scm b/gnu/packages/pciutils.scm
index acd4d5ba28..ea6bbb2702 100644
--- a/gnu/packages/pciutils.scm
+++ b/gnu/packages/pciutils.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -80,16 +81,15 @@ Each database is contained in a specific package output, such as the
(define-public pciutils
(package
(name "pciutils")
- (version "3.7.0")
+ (version "3.8.0")
(source (origin
(method url-fetch)
(uri (string-append
"mirror://kernel.org/software/utils/pciutils/pciutils-"
version ".tar.xz"))
- (patches (search-patches "pciutils-hurd-configure.patch"))
(sha256
(base32
- "1ss0rnfsx8gvqjxaji4mvbhf9xyih4cadmgadbwwv8mnx1xvjh4x"))))
+ "01aglgw9ds9qiswcbi2lx90lswncikrlyv8mmp4haix8542bvvci"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -147,18 +147,14 @@ Each database is contained in a specific package output, such as the
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
;; Install the commands, library, and .pc files.
- (invoke "make" "install" "install-lib")))
-
- ,@(if (hurd-target?)
- '((add-after 'unpack 'apply-hurd-patch
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((patch (assoc-ref inputs "hurd-patch")))
- (invoke "patch" "-p1" "--batch" "-i"
- patch)))))
- '()))
+ (invoke "make" "install" "install-lib"))))
;; Make sure programs have an RPATH so they can find libpciutils.so.
- #:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ #:make-flags (list ,(string-append "CC="
+ (if (%current-target-system)
+ (cc-for-target)
+ "gcc"))
+ (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))
;; No test suite.
@@ -169,9 +165,6 @@ Each database is contained in a specific package output, such as the
`(,@(if (not (hurd-target?))
`(("kmod" ,kmod))
'())
- ,@(if (hurd-target?)
- `(("hurd-patch" ,(search-patch "pciutils-hurd-fix.patch")))
- '())
("zlib" ,zlib)))
(home-page "https://mj.ucw.cz/sw/pciutils/")
(synopsis "Programs for inspecting and manipulating PCI devices")