aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-14 23:36:12 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit9380634c1037fa602a6d8896e94573bbf1f72396 (patch)
tree4daf036cc960ba1d3397f3e0b4f3e6891b53a863 /gnu
parentcd27b23d498c6112cbd0a4d6b03a58cf00694db4 (diff)
downloadguix-9380634c1037fa602a6d8896e94573bbf1f72396.tar.gz
guix-9380634c1037fa602a6d8896e94573bbf1f72396.zip
gnu: Remove ghc-containers.
Since GHC 7.10.2 provides containers, this package has become unneeded. * gnu/packages/haskell.scm (ghc-containers): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3bfbb8d444..a5ae4d14dc 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -966,36 +966,6 @@ constructor applications, instances of this class for primitive types, and a
variety of traversals.")
(license bsd-3)))
-(define-public ghc-containers
- (package
- (name "ghc-containers")
- (version "0.5.6.3")
- (outputs '("out" "doc"))
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://hackage.haskell.org/package/containers/containers-"
- version
- ".tar.gz"))
- (sha256
- (base32
- "1kcd55nl0vzi99i8sr8fmc5j25fv7m0a9hd3nihnq1pd64pfciqn"))))
- (build-system haskell-build-system)
- (inputs
- `(("ghc-hunit" ,ghc-hunit)
- ("ghc-quickcheck" ,ghc-quickcheck)))
- (arguments
- `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
- (home-page "http://hackage.haskell.org/package/containers")
- (synopsis "Assorted concrete container types")
- (description
- "This package contains efficient general-purpose implementations of
-various basic immutable container types. The declared cost of each operation
-is either worst-case or amortized, but remains valid even if structures are
-shared.")
- (license bsd-3)))
-
(define-public ghc-fgl
(package
(name "ghc-fgl")