aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:44:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:19 +0100
commit91e06bedf8ae43722c8c8b50816fa4e90593932e (patch)
tree37d1a484115a2f67e3757eed05b927d4fa63fc44 /gnu
parent85431ca3a8c125965477de17f2b165299b98266f (diff)
downloadguix-91e06bedf8ae43722c8c8b50816fa4e90593932e.tar.gz
guix-91e06bedf8ae43722c8c8b50816fa4e90593932e.zip
gnu: Add r-tweenr.
* gnu/packages/cran.scm (r-tweenr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 102a223c6f..b0fb5ec86a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13194,3 +13194,30 @@ efficient lookups, similar in purpose to hash tables. This package provides
an implementation of radix trees for use in R programming and in developing
packages with Rcpp.")
(license license:expat)))
+
+(define-public r-tweenr
+ (package
+ (name "r-tweenr")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tweenr" version))
+ (sha256
+ (base32
+ "0sq90pbln6lkc2q3zflhkxxwpqdw5dd7igrxhdnlynkdrmi83mpg"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-farver" ,r-farver)
+ ("r-magrittr" ,r-magrittr)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rlang" ,r-rlang)))
+ (home-page "https://github.com/thomasp85/tweenr")
+ (synopsis "Interpolate data for smooth animations")
+ (description
+ "In order to create smooth animation between states of data, tweening is
+necessary. This package provides a range of functions for creating tweened
+data that can be used as basis for animation. Furthermore it adds a number of
+vectorized interpolaters for common R data types such as numeric, date and
+color.")
+ (license license:expat)))
23f99f1a299ed0e19d926a0f719980b3c151c9c0'>profiles: Add 'package->development-manifest'.Ludovic Courtès * guix/profiles.scm (package->development-manifest): New procedure. * guix/scripts/environment.scm (input->manifest-entry) (package-environment-inputs): Remove. * guix/scripts/environment.scm (options/resolve-packages): Use 'package->development-manifest' instead of 'package-environment-inputs'. * tests/profiles.scm ("package->development-manifest"): New test. 2021-06-22profiles: Build union of inputs in the right order.Ludovic Courtès Fixes <https://bugs.gnu.org/49102>. Reported by Mathieu Othacehe <othacehe@gnu.org> and Tobias Geerinckx-Rice <me@tobias.gr>. Fixes a regression introduced in 8cef92d0633850d97c1a1d4521812268f56672be, whereby in case of file collisions, the "wrong" one would take precedence. * guix/build/profiles.scm (manifest-sexp->inputs+search-paths): Perform a breadth-first traversal. Reverse INPUTS and SEARCH-PATHS in the base case. * tests/profiles.scm ("profile-derivation, ordering & collisions"): New test. 2021-06-18profiles: Add 'load-profile'.Ludovic Courtès * guix/profiles.scm (%precious-variables): New variable. (purify-environment, load-profile): New procedures. * guix/scripts/environment.scm (%precious-variables) (purify-environment, create-environment): Remove. (launch-environment): Call 'load-profile' instead of 'create-environment'. * tests/profiles.scm ("load-profile"): New test. 2021-02-01profiles: Add 'manifest->code'.Ludovic Courtès * guix/profiles.scm (manifest->code): New procedure. * tests/profiles.scm ("manifest->code, simple") ("manifest->code, simple, versions") ("manifest->code, transformations"): New tests. 2020-12-07profiles: Delete duplicate manifest entries in packages->manifest.Leo Prikler * gnu/profiles.scm (packages->manifest): Delete duplicate entries. * tests/profiles.scm ("packages->manifest, no duplicates"): New test. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2020-12-07profiles: Remove duplicates in manifest transactions.Leo Prikler Fixes <https://bugs.gnu.org/23874>. Reported by Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>. * guix/profiles.scm (manifest-transaction-effects): Delete duplicates in install and remove. Let multiple upgrades and downgrades shadow previous transactions of the same kind. * tests/profiles.scm ("manifest-transaction-effects no double install or upgrades") ("manifest-transaction-effects no double downgrade") ("manifest-transaction-effects no double removal"): New tests. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2020-04-26profiles: Add lowerable <profile> record type.Ludovic Courtès * guix/profiles.scm (<profile>): New record type. * tests/profiles.scm ("<profile>"): New test.