aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-19 23:49:22 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:26 +0200
commit9185812a96f451164c3c56b6cf55398b6ab87647 (patch)
treef328dcad184b72f79777e701d0f817090f1e7bf1 /gnu
parent70398d7473e27323ade95c7ec42101e3d64cda7b (diff)
downloadguix-9185812a96f451164c3c56b6cf55398b6ab87647.tar.gz
guix-9185812a96f451164c3c56b6cf55398b6ab87647.zip
gnu: gitless: Add bash-minimal to inputs, use gexps.
* gnu/packages/version-control.scm (gitless) [arguments]: Use gexps. [inputs]: Add bash-minimal. Change-Id: I6f9c8661b739493ff48e114b6b063ecf12b8236a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm73
1 files changed, 36 insertions, 37 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 84198e75d3..b9fd64b3d1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -835,44 +835,43 @@ logs to GNU ChangeLog format.")
(file-name (git-file-name name version))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'loosen-requirements
- (lambda _
- (substitute* "setup.py"
- ;; Using Guix's python-pygit2 1.1.0 appears to work fine…
- (("pygit2==") "pygit2>="))
- #t))
- (add-before 'check 'prepare-for-tests
- (lambda _
- ;; Find the 'gl' command.
- (rename-file "gl.py" "gl")
- (setenv "PATH" (string-append (getcwd) ":" (getenv "PATH")))
-
- ;; The tests try to run git as if it were already set up.
- (setenv "HOME" (getcwd))
- (invoke "git" "config" "--global" "user.email" "git@example.com")
- (invoke "git" "config" "--global" "user.name" "Guix")))
- (replace 'wrap
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (git (assoc-ref inputs "git")))
- (wrap-program (string-append out "/bin/gl")
- `("PATH" ":" prefix (,(string-append git "/bin")))
- `("GUIX_PYTHONPATH" ":" =
- (,(string-append out "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages:")
- ,(getenv "GUIX_PYTHONPATH"))))
- #t))))))
- (native-inputs
- `(("git-for-tests" ,git-minimal)))
+ #~(list
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'loosen-requirements
+ (lambda _
+ (substitute* "setup.py"
+ ;; Using Guix's python-pygit2 1.1.0 appears to work fine…
+ (("pygit2==") "pygit2>="))))
+ (add-before 'check 'prepare-for-tests
+ (lambda _
+ ;; Find the 'gl' command.
+ (rename-file "gl.py" "gl")
+ (setenv "PATH" (string-append (getcwd) ":" (getenv "PATH")))
+
+ ;; The tests try to run git as if it were already set up.
+ (setenv "HOME" (getcwd))
+ (invoke "git" "config" "--global" "user.email" "git@example.com")
+ (invoke "git" "config" "--global" "user.name" "Guix")))
+ (replace 'wrap
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((out #$output)
+ (git (search-input-file inputs "bin/git")))
+ (wrap-program (string-append out "/bin/gl")
+ `("PATH" ":" prefix (,(dirname git)))
+ `("GUIX_PYTHONPATH" ":" =
+ (,(string-append out "/lib/python"
+ #$(version-major+minor
+ (package-version python))
+ "/site-packages:")
+ ,(getenv "GUIX_PYTHONPATH"))))))))))
+ (native-inputs (list git-minimal))
(inputs
- `(("git" ,git-minimal)
- ("python-clint" ,python-clint)
- ("python-pygit2" ,python-pygit2)
- ("python-sh" ,python-sh)))
+ (list bash-minimal
+ git-minimal
+ python-clint
+ python-pygit2
+ python-sh))
(home-page "https://gitless.com")
(synopsis "Simple version control system built on top of Git")
(description