aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 10:09:53 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:04 +0800
commit90e63d23c2ead567b297058fd3c69d5dc5837c03 (patch)
treed771e116b83e453bb1651b85c0288da09bf078fb /gnu
parentd8ac6016d5d6c81788a6abb7941f1e8bbe054fa5 (diff)
downloadguix-90e63d23c2ead567b297058fd3c69d5dc5837c03.tar.gz
guix-90e63d23c2ead567b297058fd3c69d5dc5837c03.zip
gnu: kdav: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (kdav): Update to 6.3.0. [inputs]: Remove kcoreaddons, qtbase-5, and qtxmlpatterns. [propagated-inputs]: Add kcoreaddons. [arguments]: Set #:qtbase to qtbase. Change-Id: Ica348f700bda694218e6f7521001663aa2f28dec
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ef23a96e70..44f66669be 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3945,7 +3945,7 @@ offers abstract functionality to deal with scripts.")
(define-public kdav
(package
(name "kdav")
- (version "5.114.0")
+ (version "6.3.0")
(source
(origin
(method url-fetch)
@@ -3953,20 +3953,23 @@ offers abstract functionality to deal with scripts.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "11959fxz24snk2l31kw8w96wah0s2fjimimrxh6xhppiy5qp2fp2"))))
+ (base32 "1f99nw6jsrka5hpp4ad13mgwprmzivv2h46vg2arjlr5x0csk4mh"))))
(build-system qt-build-system)
(native-inputs
(list extra-cmake-modules))
+ (propagated-inputs (list kcoreaddons))
(inputs
- (list kcoreaddons ki18n kio qtbase-5 qtxmlpatterns))
+ (list ki18n kio))
(arguments
- (list #:phases #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Seems to require network.
- (invoke "ctest" "-E"
- "(kdav-davcollectionsmultifetchjobtest|\
+ (list
+ #:qtbase qtbase
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Seems to require network.
+ (invoke "ctest" "-E"
+ "(kdav-davcollectionsmultifetchjobtest|\
kdav-davitemfetchjob)")))))))
(home-page "https://invent.kde.org/frameworks/kdav")
(synopsis "DAV protocol implementation with KJobs")