aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-16 16:21:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-19 00:04:55 +0200
commit8f8adb9c189560251358739d72c8bc65c13936e8 (patch)
tree74639091cb22f39f6665206c64530c7221f125bf /gnu
parent563bd8305e2419ff76e815e036ec6e351538095a (diff)
downloadguix-8f8adb9c189560251358739d72c8bc65c13936e8.tar.gz
guix-8f8adb9c189560251358739d72c8bc65c13936e8.zip
gnu: libaom: Omit static library.
* gnu/packages/video.scm (libaom)[arguments]: Add a 'delete-static-libraries phase to do so.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3a0ebf9542..6e6f84ec68 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -789,14 +789,21 @@ television and DVD. It is also known as AC-3.")
("pkg-config" ,pkg-config)
("python" ,python))) ; to detect the version
(arguments
- `(#:tests? #f ;no check target
+ `(#:tests? #f ; downloads many video clips
#:configure-flags
- ;; build dynamic library
(list "-DBUILD_SHARED_LIBS=YES"
"-DENABLE_PIC=TRUE"
"-DAOM_TARGET_CPU=generic"
(string-append "-DCMAKE_INSTALL_PREFIX="
- (assoc-ref %outputs "out")))))
+ (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'delete-static-libraries
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib")))
+ (for-each delete-file
+ (find-files lib "\\.a$"))))))))
(home-page "https://aomedia.googlesource.com/aom/")
(synopsis "AV1 video codec")
(description "Libaom is the reference implementation of AV1. It includes a