aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-01 20:26:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 15:10:42 +0000
commit8f895c52c6fd4bf1a19113a503865d511a101bea (patch)
tree384882a3f7b409365772563a5b8faafdee8fcf26 /gnu
parentfac726a4ee1ecf44b28f34a4b735010ba3a336dd (diff)
downloadguix-8f895c52c6fd4bf1a19113a503865d511a101bea.tar.gz
guix-8f895c52c6fd4bf1a19113a503865d511a101bea.zip
gnu: Add python-cosmopy.
* gnu/packages/astronomy.scm (python-cosmopy): New variable. Change-Id: I31e54ff51a2f18091baba449da3b00cdf5088b15
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 120ea63dd5..fd73a7f8e1 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1961,6 +1961,34 @@ JSON template file alongside Python routines for visualizing and comparing
lens models possibly obtained from different modeling codes.")
(license license:gpl3)))
+(define-public python-cosmopy
+ (package
+ (name "python-cosmopy")
+ (version "3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cosmopy" version))
+ (sha256
+ (base32 "16xlg0vyzdx1h5h28y8az48nhiqvx43yd9s30g3rk9ywl4r1j6h8"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-astropy
+ python-click
+ python-future
+ python-numpy
+ python-scipy))
+ (home-page "https://github.com/lzkelley/cosmopy")
+ (synopsis "Cosmological calculator in Python")
+ (description
+ "This package provides a CLI and Python module to quickly calculate
+cosmological parameters e.g. redshift or luminosity-distance.")
+ (license license:expat)))
+
(define-public python-czml3
(package
(name "python-czml3")