aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-09 22:54:51 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:45 +0000
commit8f473d8cffadeade7f190f486e745139b1424a2f (patch)
treef4491c4877d9dc2425d32826137014e69f857890 /gnu
parentd3a22534c6e5887f38fe071e5f9561eb05be64c2 (diff)
downloadguix-8f473d8cffadeade7f190f486e745139b1424a2f.tar.gz
guix-8f473d8cffadeade7f190f486e745139b1424a2f.zip
gnu: python-sphinx-5: Disable failing tests.
* gnu/packages/sphinx.scm (python-sphinx-5)[arguments]: Disable three tests that fail for silly reasons. Change-Id: I82d9fd4465fbfe052f8aad2264a9b04d34efef89
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sphinx.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index b22a288234..4b2e12adc4 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -184,7 +184,15 @@ sources.")
"not test_latex_images"
;; XXX: Not clear why this fails with a version comparison
;; failure.
- " and not test_needs_sphinx"))
+ " and not test_needs_sphinx"
+ ;; This is a harmless failure. The expected output looks for a
+ ;; long string that happens to contain a literal space
+ ;; character, but in the actual output the space character is
+ ;; wrapped in <span class="w"> </span>.
+ " and not test_viewcode"
+ ;; These fail with pygments 2.10+. They are harmless.
+ " and not test_additional_targets_should_not_be_translated"
+ " and not test_additional_targets_should_be_translated"))
#:phases
'(modify-phases %standard-phases
(add-before 'check 'pre-check