aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:12:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:33:15 +0200
commit8f0657a88ae2f0378d98a332de9473bfb63bb840 (patch)
treeee972412a3cc6af96dffb198a4da5ed9fad31b48 /gnu
parent70c1b960d4104073b3378d0c42ff3e65de16e400 (diff)
downloadguix-8f0657a88ae2f0378d98a332de9473bfb63bb840.tar.gz
guix-8f0657a88ae2f0378d98a332de9473bfb63bb840.zip
gnu: Add texlive-thaispec.
* gnu/packages/tex.scm (texlive-thaispec): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index adb4018264..87004d9f53 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9914,6 +9914,28 @@ or @code{\\thaimultialph*} in conjunction with the package @code{enumitem}.
Concrete examples are given in the documentation.")
(license license:lppl1.3+)))
+(define-public texlive-thaispec
+ (package
+ (name "texlive-thaispec")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/thaispec/"
+ "source/latex/thaispec/"
+ "tex/latex/thaispec/")
+ (base32
+ "1d0mj98akv7bfq3msaplm2pffcwfayssn4i5an12zrw0wxicmp96")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/thaispec")
+ (synopsis "Thai language typesetting in XeLaTeX")
+ (description
+ "This package allows you to input Thai characters directly to LaTeX
+documents and choose any (system wide) Thai fonts for typesetting in XeLaTeX.
+It also tries to appropriately justify paragraphs with no more external
+tools.")
+ (license license:lppl1.3+)))
+
(define-public texlive-thermodynamics
(package
(name "texlive-thermodynamics")