aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 00:30:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:15 +0200
commit8f02e31cad788f3face1081bf2d29aee09b48fa4 (patch)
tree28e863409807e8a4cfc76bd07f138248ccd1ce8c /gnu
parent2b125a99d68021e3b04a2e42c37af8a4c0af1324 (diff)
downloadguix-8f02e31cad788f3face1081bf2d29aee09b48fa4.tar.gz
guix-8f02e31cad788f3face1081bf2d29aee09b48fa4.zip
gnu: Add texlive-genealogytree.
* gnu/packages/tex.scm (texlive-genealogytree): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ae44457083..f0535b47c5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17275,6 +17275,29 @@ TeX implementation, running in any current environment, requires the
interpreter, not just LuaTeX.")
(license license:lppl)))
+(define-public texlive-genealogytree
+ (package
+ (name "texlive-genealogytree")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/genealogytree/"
+ "tex/latex/genealogytree/")
+ (base32
+ "10h12qgjrh37ax1grpkyas5blf3s4g6bfp6g5d9x7y1ddfpxjmix")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/genealogytree")
+ (synopsis "Pedigree and genealogical tree diagrams")
+ (description
+ "Pedigree and genealogical tree diagrams are proven tools to visualize
+genetic and relational connections between individuals. The package provides
+a set of tools to typeset genealogical trees, i.e., to typeset a set of
+special graphs for the description of family-like structures. The package
+uses an autolayout algorithm which can be customized, e.g., to prioritize
+certain paths.")
+ (license license:lppl1.3+)))
+
(define-public texlive-inlinedef
(package
(name "texlive-inlinedef")