aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 21:53:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:59 +0200
commit8e9133cc680d08d8aef3a0d5f48e06a1a6039d61 (patch)
tree42c12d40db47bbbae3b3dd4e436a08c2a01b4f25 /gnu
parent290b7ee1d57d89359bb7facc890c6d30e61aada2 (diff)
downloadguix-8e9133cc680d08d8aef3a0d5f48e06a1a6039d61.tar.gz
guix-8e9133cc680d08d8aef3a0d5f48e06a1a6039d61.zip
gnu: Add texlive-blox.
* gnu/packages/tex.scm (texlive-blox): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9023025209..33bc3c25e7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16289,6 +16289,36 @@ within a @code{tikzpicture} environment by setting the environment option
diagrams (specially in power electronics).")
(license license:lppl1.3+)))
+(define-public texlive-blox
+ (package
+ (name "texlive-blox")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/blox/" "source/latex/blox/"
+ "tex/latex/blox/")
+ (base32
+ "0xkv6rvkbchkwgfam5kiymng0xnc4vja5xb3b5d89rngdr041xwk")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:tex-format "latex"))
+ (native-inputs
+ (list (texlive-updmap.cfg
+ (list texlive-fancyvrb
+ texlive-hypdoc
+ texlive-hyperref
+ texlive-infwarerr
+ texlive-kvoptions
+ texlive-pgf
+ texlive-tools))))
+ (home-page "https://ctan.org/pkg/blox")
+ (synopsis "Draw block diagrams, using TikZ")
+ (description
+ "This package, along with TikZ, will typeset block diagrams for use with
+programming and control theory. It is an English translation of the
+@code{schemabloc} package.")
+ (license license:lppl1.3+)))
+
(define-public texlive-gates
(package
(name "texlive-gates")