aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 22:15:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:07 +0200
commit8d585145ea5a4a217f3a3f2e82feba1a3e2f2a25 (patch)
tree0e40813a3eb3bb07dc0c1bedcdfbee0995b2fd9a /gnu
parentaff44b98e33da7f8e784077370bae176d08ffa9f (diff)
downloadguix-8d585145ea5a4a217f3a3f2e82feba1a3e2f2a25.tar.gz
guix-8d585145ea5a4a217f3a3f2e82feba1a3e2f2a25.zip
gnu: Add texlive-ditaa.
* gnu/packages/tex.scm (texlive-ditaa): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f8913b5f91..1e39c1e1a9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16753,6 +16753,24 @@ arrows (morphism), positioned in a Cartesian coordinate system.")
using @code{pict2e} so that the restrictions on line direction are removed.")
(license license:lppl)))
+(define-public texlive-ditaa
+ (package
+ (name "texlive-ditaa")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ditaa/" "tex/latex/ditaa/")
+ (base32
+ "1dk915p169hnpy9888kpslawhkmlipbkdrsnk1pajypcl7jyrniw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ditaa")
+ (synopsis "Use ditaa diagrams within LaTeX documents")
+ (description
+ "With this package, @acronym{DITAA, DIagrams Through Ascii Art} diagrams
+can be embedded directly into LaTeX files.")
+ (license license:lppl)))
+
(define-public texlive-gates
(package
(name "texlive-gates")