aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 01:04:26 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:02 +0800
commit8c304250f7dcede19f57b6776181cd808e43f37c (patch)
tree31ed64c944a9b74572197997e216649b138166c5 /gnu
parente64392fdf131ba125b77f373b3442b1c985fd49a (diff)
downloadguix-8c304250f7dcede19f57b6776181cd808e43f37c.tar.gz
guix-8c304250f7dcede19f57b6776181cd808e43f37c.zip
gnu: kauth: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (kauth): Update to 6.3.0. [inputs]: Remove kcoreaddons, polkit-qt, and qtbase-5; add kwindowsystem, polkit-qt6, and qtbase. [propagated-inputs]: Add kcoreaddons. [native-inputs]: Remove qttools-5; add qttools. [arguments]: Adjust fix-cmake-install-directories phase. Change-Id: I93d498aeb5405e1bc044960b5d5cf34de1910d78
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 1719ac994f..e930222b20 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1634,7 +1634,7 @@ with other frameworks.")
(define-public kauth
(package
(name "kauth")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1643,12 +1643,13 @@ with other frameworks.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1rkf9mc9718wn8pzd3d3wcg3lsn0vkr9a2cqnz86rbg3cf2qdbir"))))
+ "1d9kmxbb3rx4nx1yq0crywirmnnp8qvhs2pdng7s49pqdy0kdkzb"))))
(build-system cmake-build-system)
(native-inputs
- (list dbus extra-cmake-modules qttools-5))
+ (list dbus extra-cmake-modules qttools))
+ (propagated-inputs (list kcoreaddons))
(inputs
- (list kcoreaddons polkit-qt qtbase-5))
+ (list kwindowsystem polkit-qt6 qtbase))
(arguments
(list
#:phases
@@ -1657,7 +1658,9 @@ with other frameworks.")
(lambda _
;; Make packages using kauth put their policy files and helpers
;; into their own prefix.
- (substitute* "KF5AuthConfig.cmake.in"
+ (substitute* #$(string-append "KF" (version-major
+ (package-version this-package))
+ "AuthConfig.cmake.in")
(("@KAUTH_POLICY_FILES_INSTALL_DIR@")
"${KDE_INSTALL_DATADIR}/polkit-1/actions")
(("@KAUTH_HELPER_INSTALL_DIR@")