aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-19 20:27:25 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-19 21:21:01 +0200
commit8c1db4fc58859f3fbdf098da1791f5e84f9092ce (patch)
tree22910325435e1df5b868f7be9b299f548e21b09b /gnu
parent43dc47fa249aebe3b5cbc0141c2be4ba226e92bf (diff)
downloadguix-8c1db4fc58859f3fbdf098da1791f5e84f9092ce.tar.gz
guix-8c1db4fc58859f3fbdf098da1791f5e84f9092ce.zip
gnu: yadifa: Update to 2.2.6.
* gnu/packages/dns.scm (yadifa): Update to 2.2.6.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/dns.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 657e7eb2a4..ee5acaf3eb 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -443,9 +443,9 @@ served by AS112. Stub and forward zones are supported.")
(define-public yadifa
(package
(name "yadifa")
- (version "2.2.5")
+ (version "2.2.6")
(source
- (let ((build "6937"))
+ (let ((build "7246"))
(origin
(method url-fetch)
(uri
@@ -453,7 +453,7 @@ served by AS112. Stub and forward zones are supported.")
name "-" version "-" build ".tar.gz"))
(sha256
(base32
- "146fs52izf6dfwsxal3srpwin2yyl41g31cy4pyvbi5mqy2craj7")))))
+ "041a35f5jz2wcn8pxk1m7b2qln2wbvj4ddwb0a53lqabl912xi6p")))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)))
(cut search-path %load-path <>)) '("guix.scm" "guix/build/syscalls.scm" "guix/packages.scm"))))) (call-with-temporary-output-file (lambda (ref-file _) (let ((pipe (open-pipe* OPEN_WRITE %cpio-program "-o" "-O" ref-file "-H" "newc" "--null"))) (for-each (lambda (file) (format pipe "~a\0" file)) files) (and (zero? (close-pipe pipe)) (call-with-temporary-output-file (lambda (file port) (write-cpio-archive files port) (close-port port) (or (file=? ref-file file) (throw 'cpio-archives-differ files ref-file file (stat:size (stat ref-file)) (stat:size (stat file)))))))))))))) (test-end "cpio")