aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2021-11-10 09:52:11 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-12 17:23:01 +0000
commit8ab799faaba83100251bbdb17ac39d52c5cf6894 (patch)
tree3d8c10dc038af228ff0b8853c39c689a3f63be24 /gnu
parent90b737bb8de7ed2608c54e8ec19496b15db87a0f (diff)
downloadguix-8ab799faaba83100251bbdb17ac39d52c5cf6894.tar.gz
guix-8ab799faaba83100251bbdb17ac39d52c5cf6894.zip
gnu: gnome-boxes: Don’t use bundled libhandy.
* gnu/packages/gnome.scm (gnome-boxes) [inputs]: Add libhandy. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fbcc84e1df..f903405401 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11642,6 +11642,7 @@ integrate seamlessly with the GNOME desktop.")
("gtk-vnc" ,gtk-vnc)
("gtksourceview" ,gtksourceview)
("json-glib" ,json-glib)
+ ("libhandy" ,libhandy)
("libosinfo" ,libosinfo)
("libsecret" ,libsecret)
("libsoup" ,libsoup)
hyg1amjl0acic3agj20spcpv5m0ncg1283mmxs8cs3xy9")) (patches (list (origin (method url-fetch) (uri "https://sources.debian.org/data/main/p/presentty/0.2.1-1/debian/patches/presentty-python3.patch") (sha256 (base32 "03d3ylh1z99g4dqj7aka60spagnwss9mbacd7jbpk1gazflnssz1"))))))) (build-system python-build-system) (arguments `(#:tests? #f ; Test suite hasn't withstood the test of time. #:phases (modify-phases %standard-phases (replace 'wrap (lambda* (#:key python inputs outputs #:allow-other-keys) (let* ((out (assoc-ref outputs "out")) (bin (string-append out "/bin/")) (python (assoc-ref inputs "python"))) (for-each (lambda (program) (wrap-program (string-append bin program) `("PATH" ":" prefix (,(dirname (which "cowsay")) ,(dirname (which "figlet")) ,(dirname (which "jp2a")))) `("PYTHONPATH" prefix ,(cons (string-append out "/lib/python" (python-version python) "/site-packages") (search-path-as-string->list (or (getenv "PYTHONPATH") "")))))) '("presentty" "presentty-console"))) #t))))) (inputs `(("cowsay" ,cowsay) ("figlet" ,figlet) ("jp2a" ,jp2a) ("python-docutils" ,python-docutils) ("python-pillow" ,python-pillow-2.9) ("python-six" ,python-six) ("python-urwid" ,python-urwid))) (native-inputs `(("python-pbr" ,python-pbr) ("python-pygments" ,python-pygments))) (home-page "http://git.inaugust.com/cgit/presentty/") (synopsis "Console-based presentation system") (description "Presentty is a console-based presentation program where slides are authored in reStructuredText. Its features include, but are not limited to: Cross-fade animations, progressive list display, panning transitions, syntax highlighting, Cowsay and figlet integration, ANSI art, JPEG display.") (license license:gpl3+)))