aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-12-13 20:58:29 +0100
committerVagrant Cascadian <vagrant@debian.org>2024-12-18 14:24:52 -0800
commit8a016fa0562e7f23b32a3fa25542b19af64b9c0e (patch)
treeb47095cb2b8f5b1606388ca731245a3f4c9ba5e1 /gnu
parent6f7778e5da7e9a655109ca4cf021e7507f44e7d3 (diff)
downloadguix-8a016fa0562e7f23b32a3fa25542b19af64b9c0e.tar.gz
guix-8a016fa0562e7f23b32a3fa25542b19af64b9c0e.zip
Revert "gnu: u-boot-tools: Fix segfault while running tests."
This reverts commit e526b8b11debb184929abd013b7d589c9db245fa. Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bootloaders.scm3
-rw-r--r--gnu/packages/patches/u-boot-calloc-visibility.patch18
3 files changed, 1 insertions, 21 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e99b00ed93..ad9ce6c50f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2275,7 +2275,6 @@ dist_patch_DATA = \
%D%/packages/patches/twinkle-bcg729.patch \
%D%/packages/patches/u-boot-allow-disabling-openssl.patch \
%D%/packages/patches/u-boot-build-without-libcrypto.patch \
- %D%/packages/patches/u-boot-calloc-visibility.patch \
%D%/packages/patches/u-boot-nintendo-nes-serial.patch \
%D%/packages/patches/u-boot-rockchip-inno-usb.patch \
%D%/packages/patches/ucx-tcp-iface-ioctl.patch \
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 0e27113155..e6d83d5329 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -767,8 +767,7 @@ tree binary files. These are board description files used by Linux and BSD.")
(patches
(list %u-boot-rockchip-inno-usb-patch
%u-boot-build-without-libcrypto-patch
- %u-boot-allow-disabling-openssl-patch
- (search-patch "u-boot-calloc-visibility.patch")))
+ %u-boot-allow-disabling-openssl-patch))
(method url-fetch)
(uri (string-append
"https://ftp.denx.de/pub/u-boot/"
diff --git a/gnu/packages/patches/u-boot-calloc-visibility.patch b/gnu/packages/patches/u-boot-calloc-visibility.patch
deleted file mode 100644
index 93c52ff709..0000000000
--- a/gnu/packages/patches/u-boot-calloc-visibility.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Arrange so that LLVM's shared object doesn't end up using 'calloc' from
-U-Boot's 'malloc_simple.c' when it's initialized.
-
- https://issues.guix.gnu.org/74270
-
-diff --git a/common/malloc_simple.c b/common/malloc_simple.c
-index 5a8ec538f8..4f5e350a3c 100644
---- a/common/malloc_simple.c
-+++ b/common/malloc_simple.c
-@@ -64,6 +64,8 @@ void *memalign_simple(size_t align, size_t bytes)
- }
-
- #if CONFIG_IS_ENABLED(SYS_MALLOC_SIMPLE)
-+void *calloc(size_t nmemb, size_t elem_size)
-+ __attribute__ ((visibility ("hidden")));
- void *calloc(size_t nmemb, size_t elem_size)
- {
- size_t size = nmemb * elem_size;