aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-20 11:22:24 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-03-20 18:27:44 +0200
commit86f1a3643ed37ede7ab1cdfd8387bf3e43ff8ba1 (patch)
treee8fc90ebb307186087cdf5ae5b0895edc915cba2 /gnu
parente0deaf0a85a1a6a0f8e6d619d25495eb1b621c2a (diff)
downloadguix-86f1a3643ed37ede7ab1cdfd8387bf3e43ff8ba1.tar.gz
guix-86f1a3643ed37ede7ab1cdfd8387bf3e43ff8ba1.zip
gnu: Add python-google-api-core-1.
* gnu/packages/python-web.scm (python-google-api-core-1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ca41684542..ef09c05a81 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7388,6 +7388,52 @@ common protos in the @code{googleapis/api-common-protos} repository.")
clients.")
(license license:asl2.0)))
+(define-public python-google-api-core-1
+ (package
+ (inherit python-google-api-core)
+ (name "python-google-api-core")
+ (version "1.32.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "google-api-core" version))
+ (sha256
+ (base32 "0709va9sisll7axkv6ii2x5s0ls38rqp1jnvs6nkpmg7z163q70h"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (for-each
+ delete-file
+ '(;; The test suite can't find AsyncMock.
+ "tests/asyncio/test_page_iterator_async.py"
+ "tests/asyncio/test_retry_async.py"
+ ;; Skip the tests depending on grpc.
+ "tests/asyncio/test_operation_async.py"
+ "tests/asyncio/test_grpc_helpers_async.py"
+ "tests/asyncio/operations_v1/test_operations_async_client.py"
+ "tests/unit/test_bidi.py"
+ "tests/unit/test_exceptions.py"
+ "tests/unit/test_grpc_helpers.py"
+ "tests/unit/test_operation.py"
+ "tests/unit/operations_v1/test_operations_client.py"))
+ (delete-file-recursively "tests/asyncio/gapic")
+ (delete-file-recursively "tests/unit/gapic")
+ (invoke "pytest" "-k" "not test_constructor_defaults")))))))
+ (propagated-inputs
+ (list python-google-auth-1
+ python-googleapis-common-protos
+ python-packaging
+ python-protobuf
+ python-proto-plus
+ python-pytz
+ python-requests))
+ (native-inputs
+ (list python-pytest
+ python-pytest-asyncio))))
+
(define-public python-google-cloud-core
(package
(name "python-google-cloud-core")