aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-09 00:40:08 +0100
committerChristopher Baines <mail@cbaines.net>2023-10-11 12:11:41 +0100
commit8647a2d4b10f9378d759c6a946de9295dffe9b27 (patch)
tree77fde678496c15ee3263a1ce8716203d3937f632 /gnu
parentdf3a912498818a6b710ed48ae6a06863633a52d6 (diff)
downloadguix-8647a2d4b10f9378d759c6a946de9295dffe9b27.tar.gz
guix-8647a2d4b10f9378d759c6a946de9295dffe9b27.zip
gnu: python-jplephem: Improve package style.
* gnu/packages/astronomy.scm (python-jplephem)[build-system]: Shift to pyproject-build-system. [arguments]: Use G-expressions. Simplify 'check phase. [description]: Extend it with more details. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 75ae4f0229..190deffdf2 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3238,24 +3238,25 @@ Moon position, etc.")
(uri (pypi-uri "jplephem" version))
(sha256
(base32 "1kvdzwyh0invinvcnwfr14r9zbqzcwkdh0cpzw1m4vkdcm64aqn1"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (let ((out (assoc-ref outputs "out")))
- (add-installed-pythonpath inputs outputs)
- (setenv "PATH" (string-append out "/bin:" (getenv "PATH")))
- (invoke "python" "-m" "unittest" "discover" "-s" "test"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest" "discover" "-s" "test")))))))
(inputs
(list python-numpy))
(home-page "https://github.com/brandon-rhodes/python-jplephem")
(synopsis "Python version of NASA DE4xx ephemerides")
(description
- "The package is a Python implementation of the mathematics that standard
-JPL ephemerides use to predict raw (x,y,z) planetary positions.")
+ "@code{skyfield} computes positions for the stars, planets, and
+satellites in orbit around the Earth. Its results should agree with the
+positions generated by the United States Naval Observatory and their
+Astronomical Almanac to within 0.0005 arcseconds (half a @emph{mas} or
+milliarcsecond).")
(license license:expat)))
(define-public python-jwst