aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:53:40 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commit857be8fb4713a399120e3357ccb02a89989a7675 (patch)
tree7fc85140acd624d8db1db65589e4f03c4f6108de /gnu
parentfb63bfb9d5d1983aaa67d2ba6447ba7cb71769a6 (diff)
downloadguix-857be8fb4713a399120e3357ccb02a89989a7675.tar.gz
guix-857be8fb4713a399120e3357ccb02a89989a7675.zip
gnu: go-lukechampine-com-blake3: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-lukechampine-com-blake3): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/uucp.scm: Add (gnu packages golang-crypto) to used modules. Change-Id: I56dba8380317a0f58f92140889611ac3075af2cf
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-crypto.scm26
-rw-r--r--gnu/packages/golang.scm27
-rw-r--r--gnu/packages/uucp.scm1
3 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 91def02194..bfeea103ca 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
;;; Copyright © 2022, 2023 Nicolas Graves <ngraves@ngraves.fr>
@@ -612,6 +613,31 @@ package is intended for interoperability with the standard library and the
possible.")
(license license:bsd-3))))
+(define-public go-lukechampine-com-blake3
+ (package
+ (name "go-lukechampine-com-blake3")
+ (version "1.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lukechampine/blake3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yxdwp8dpnnq2wbwsxlkbq570i99sc6781y39czjxi9jh9z5nw55"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "lukechampine.com/blake3"))
+ (propagated-inputs
+ (list go-github-com-klauspost-cpuid))
+ (home-page "https://pkg.go.dev/lukechampine.com/blake3")
+ (synopsis "Implementation of the BLAKE3 cryptographic hash function")
+ (description "@code{blake3} implements the BLAKE3 cryptographic hash
+function. In addition to the pure-Go implementation, this package also
+contains AVX-512 and AVX2 routines (generated by avo) that greatly increase
+performance for large inputs and outputs.")
+ (license license:expat)))
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ecfb1ecfc6..7d19b98253 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10451,33 +10451,6 @@ friendly sizes. It converts boring ugly numbers to human-friendly strings and
back.")
(license license:expat)))
-(define-public go-lukechampine-com-blake3
- (package
- (name "go-lukechampine-com-blake3")
- (version "1.1.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lukechampine/blake3")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1yxdwp8dpnnq2wbwsxlkbq570i99sc6781y39czjxi9jh9z5nw55"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "lukechampine.com/blake3"))
- (propagated-inputs
- (list go-github-com-klauspost-cpuid))
- (home-page "https://pkg.go.dev/lukechampine.com/blake3")
- (synopsis "Implementation of the BLAKE3 cryptographic hash function")
- (description "@code{blake3} implements the BLAKE3 cryptographic hash
-function. In addition to the pure-Go implementation, this package also
-contains AVX-512 and AVX2 routines (generated by avo) that greatly increase
-performance for large inputs and outputs.")
- (license license:expat)))
-
(define-public go-golang-org-x-term
(package
(name "go-golang-org-x-term")
diff --git a/gnu/packages/uucp.scm b/gnu/packages/uucp.scm
index 1626c90c36..37dc27625a 100644
--- a/gnu/packages/uucp.scm
+++ b/gnu/packages/uucp.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages uucp)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-crypto)
#:use-module (gnu packages golang-web)
#:use-module (gnu packages texinfo)
#:use-module (guix licenses)