aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-02-18 22:02:21 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:40:49 +0300
commit852e6f7cc24538ab2dd0a71634f53d24994e05ca (patch)
tree9413714d6e1fb05622d394cd9d116cbd3e06b67e /gnu
parentf2b6fd5485f87b5ee0d70b3c083cfea2375868ed (diff)
downloadguix-852e6f7cc24538ab2dd0a71634f53d24994e05ca.tar.gz
guix-852e6f7cc24538ab2dd0a71634f53d24994e05ca.zip
gnu: Place rust-rt-format-0.3 in alphabetical order.
gnu/packages/crates-io.scm (rust-rt-format-0.3): Move variable. Change-Id: I71364774e17b776c43b696791a98c01e62655c10 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm52
1 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f8cc568a5e..3ec3f58bcd 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16228,32 +16228,6 @@ many formats including AAC, FLAC, MP3, MP4 and WAV.")
backwards compatibility guarantees.")
(license license:asl2.0)))
-(define-public rust-rt-format-0.3
- (package
- (name "rust-rt-format")
- (version "0.3.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "rt-format" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1qjjwh9ny95xck1kp99gi6hfm9glrx54jx8npnj6yccxc7p7q225"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-regex" ,rust-regex-1))))
- (home-page "https://github.com/vstojkovic/rt-format")
- (synopsis "Runtime equivalent of the Rust format! macro")
- (description "This package provides a runtime equivalent of the Rust
-format! macro. It allows formatting strings like the format! macro, with the
-formatting string and the arguments provided at runtime. This crate supports
-all the formatting features of the format! macro, except for the fill
-character.")
- (license license:asl2.0)))
-
(define-public rust-cssparser-0.29
(package
(name "rust-cssparser")
@@ -56380,6 +56354,32 @@ tests.")
("rust-rstest" ,rust-rstest-0.15)
("rust-temp-testdir" ,rust-temp-testdir-0.2))))))
+(define-public rust-rt-format-0.3
+ (package
+ (name "rust-rt-format")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rt-format" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1qjjwh9ny95xck1kp99gi6hfm9glrx54jx8npnj6yccxc7p7q225"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-regex" ,rust-regex-1))))
+ (home-page "https://github.com/vstojkovic/rt-format")
+ (synopsis "Runtime equivalent of the Rust format! macro")
+ (description "This package provides a runtime equivalent of the Rust
+format! macro. It allows formatting strings like the format! macro, with the
+formatting string and the arguments provided at runtime. This crate supports
+all the formatting features of the format! macro, except for the fill
+character.")
+ (license license:asl2.0)))
+
(define-public rust-rtnetlink-0.14
(package
(name "rust-rtnetlink")