aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-31 00:07:06 -0500
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:46 +0200
commit84728d5ba408c11344f78a6da50fd720d74e3c0a (patch)
tree5f03760563e687179744a7e28bc2355198eb135e /gnu
parenta9bd08f8f5012628a0f3c02e3cdb683c5ecec5b1 (diff)
downloadguix-84728d5ba408c11344f78a6da50fd720d74e3c0a.tar.gz
guix-84728d5ba408c11344f78a6da50fd720d74e3c0a.zip
gnu: Do not eagerly load (gnu packages commencement).
As its top comment says, this module is not meant to be imported to avoid circular module dependencies. * gnu/packages/chicken.scm (chicken) [propagated-inputs]: Resolve gcc-toolchain lazily. * gnu/packages/plan9.scm (plan9port): Likewise. * gnu/packages/raspberry-pi.scm (raspi-arm64-chainloader) [native-inputs]: Resolve ld-wrapper lazily. Change-Id: Ie9859046ed32b67dc53bcc5444d6ae162e5d4022
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/chicken.scm7
-rw-r--r--gnu/packages/plan9.scm5
-rw-r--r--gnu/packages/raspberry-pi.scm5
3 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 8f5e8ce98d..3743ae3e2a 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -26,7 +26,6 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix svn-download)
- #:use-module (gnu packages commencement)
#:use-module ((guix licenses)
#:prefix license:))
@@ -68,7 +67,11 @@
(variable "CHICKEN_REPOSITORY_PATH")
;; TODO extract binary version into a module level definition.
(files (list "var/lib/chicken/11")))))
- (propagated-inputs (list gcc-toolchain))
+ ;; Reference gcc-toolchain lazily to avoid circular module dependency
+ ;; problems.
+ (propagated-inputs (list (module-ref (resolve-interface
+ '(gnu packages commencement))
+ 'gcc-toolchain)))
(home-page "https://www.call-cc.org/")
(synopsis "R5RS Scheme implementation that compiles native code via C")
(description
diff --git a/gnu/packages/plan9.scm b/gnu/packages/plan9.scm
index 862eeb9802..cb170c76ac 100644
--- a/gnu/packages/plan9.scm
+++ b/gnu/packages/plan9.scm
@@ -26,7 +26,6 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
- #:use-module (gnu packages commencement)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages linux)
@@ -180,7 +179,9 @@ reconstruct a Plan 9 terminal-like experience from a non-Plan 9 system.")
fontconfig libx11 libxext libxt))
;; Propagate gcc-toolchain because some programs, like the 9c compiler,
;; are just aliased scripts to gcc equivalents.
- (propagated-inputs (list gcc-toolchain))
+ (propagated-inputs (list (module-ref (resolve-interface
+ '(gnu packages commencement))
+ 'gcc-toolchain)))
(home-page "https://9fans.github.io/plan9port/")
(synopsis "Port of many Plan 9 libraries and programs")
(description
diff --git a/gnu/packages/raspberry-pi.scm b/gnu/packages/raspberry-pi.scm
index c4f03c3ed9..216c74cb9c 100644
--- a/gnu/packages/raspberry-pi.scm
+++ b/gnu/packages/raspberry-pi.scm
@@ -28,7 +28,6 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bootloaders)
- #:use-module (gnu packages commencement)
#:use-module (gnu packages cross-base)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
@@ -196,7 +195,9 @@ Raspberry Pi. Note: It does not work on Raspberry Pi 1.")
("binutils" ,binutils)
("coreutils" ,coreutils)
("file" ,file)
- ("ld-wrapper" ,ld-wrapper)
+ ("ld-wrapper" ,(module-ref (resolve-interface
+ '(gnu packages commencement))
+ 'ld-wrapper))
("make" ,gnu-make)
("gcc" ,gcc-6)
("locales" ,(libc-utf8-locales-for-target))))