aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-11 00:11:15 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-21 22:52:50 +0800
commit83304896fdbc148ea8ff08a10955d52d7cd36a27 (patch)
tree3827ba3ed53da4b36e08ffedde7e4e10ce368b1e /gnu
parent82bcaf759377ebea6e594be0034a9952f11260dd (diff)
downloadguix-83304896fdbc148ea8ff08a10955d52d7cd36a27.tar.gz
guix-83304896fdbc148ea8ff08a10955d52d7cd36a27.zip
gnu: qtsensors: Update to 6.7.2.
* gnu/packages/qt.scm (qtsensors): Update to 6.7.2. Change-Id: I3a869f4fdb2e9df5d0600d9994a85ecfd7e0460a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a9c11ef9c2..dec0ec3fc3 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1760,13 +1760,13 @@ consume data received from the server, or both.")
(package
(inherit qtsvg)
(name "qtsensors")
- (version "6.6.3")
+ (version "6.7.2")
(source (origin
(method url-fetch)
(uri (qt-url name version))
(sha256
(base32
- "0r9p3lm159pji29vq9kii42jkz4rg15hqh6zlq9442i58a0ayddj"))))
+ "0ndvwra9bssfqw32bk5mbj3zdqgi9zshm0gd0bfd8vn5hz3xxlga"))))
(native-inputs (list qtdeclarative))
(inputs (list qtbase))
(synopsis "Qt Sensors module")
cm?id=bc5155b952ae8bdbc56aded4d8d39768b4e2a7d4'>Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-10-28store: 'map/accumulate-builds' handler checks the store received....This is a followup to b19250eec6f92308f237a09a43e8e3e2355345b9, providing a proper fix for <https://issues.guix.gnu.org/46756>. * guix/remote.scm (remote-eval): Revert b19250eec6f92308f237a09a43e8e3e2355345b9. * guix/store.scm (build-accumulator): Turn into a procedure. Call CONTINUE when the store is not eq? to the initial store. (map/accumulate-builds): Adjust accordingly. * tests/store.scm ("map/accumulate-builds and different store"): New test. Ludovic Courtès 2021-09-17Merge branch 'master' into core-updates-frozen... Conflicts: gnu/packages/bioinformatics.scm gnu/packages/chez.scm gnu/packages/docbook.scm gnu/packages/ebook.scm gnu/packages/gnome.scm gnu/packages/linux.scm gnu/packages/networking.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/tex.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/dune.scm guix/build-system/go.scm guix/build-system/linux-module.scm guix/packages.scm Marius Bakke 2021-09-15store: 'map/accumulate-builds' processes the whole list in case of cutoff....Fixes <https://issues.guix.gnu.org/50264>. Reported by Lars-Dominik Braun <lars@6xq.net>. This fixes a regression introduced in fa81971cbae85b39183ccf8f51e8d96ac88fb4ac whereby 'map/accumulate-builds' would return REST (the tail of LST) without applying PROC on it. The effect would be that 'lower-inputs' in (guix gexp) would dismiss those elements, leading to derivations with correct builders but only a subset of the inputs they should have had. * guix/store.scm (map/accumulate-builds): Add #:cutoff parameter and remove 'accumulation-cutoff' variable. Call PROC on the elements of REST. * tests/store.scm ("map/accumulate-builds cutoff"): New test. Ludovic Courtès 2021-07-05tests: Fix typo in 'tests/store.scm'....This typo had always been there since the test was introduced in commit ce72c780746776a86f59747f5eff8731cb4ff39b. Presumably, it became visible with 9e5812ac59b01ff011ec0c5b0f437dfe85d6fcc7, where caching was no longer global and thus the 'store' argument of 'package-derivation' was actually being used. * tests/store.scm ("current-build-output-port, UTF-8"): Refer to '%store' rather than 's' in 'package-derivation' call. Ludovic Courtès