aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2024-10-17 18:25:59 +0200
committerLudovic Courtès <ludo@gnu.org>2024-10-22 00:27:50 +0200
commit82bfac0a66deae41c03b21df94dc86aaad102ea7 (patch)
tree272395fe29ee4210597699f2963abc699059da3d /gnu
parent91121714644264c2b7081588f07feb71610303cf (diff)
downloadguix-82bfac0a66deae41c03b21df94dc86aaad102ea7.tar.gz
guix-82bfac0a66deae41c03b21df94dc86aaad102ea7.zip
gnu: dwl: Update to 0.6.
* gnu/packages/wm.scm (dwl): Update to 0.6. [origin]<url>: Update repository url. [homepage]: Update homepage. [arguments]: Convert to G-exps, use #$output instead of assoc-ref. [inputs]: Remove wlroots-0.16; add wlroots. Change-Id: I567a99e88a899953049a9ce00d699ea73ee08c14 Signed-off-by: Noé Lopez <noelopez@free.fr> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 38cb8cc717..bfc1f6c449 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1597,31 +1597,31 @@ started automatically on the first call via D-Bus.")
(define-public dwl
(package
(name "dwl")
- (version "0.4")
+ (version "0.6")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/djpohly/dwl")
+ (url "https://codeberg.org/dwl/dwl")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0pj0h3zd2f60hxpavpmgzid1sj7hf9m5cgclbackljqq4gpwlvir"))))
+ "1j7lmp6k80g54hrsmwixh8ahpnbax4khgiybg8lhlvmq93618a3z"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list
- (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure
+ (list #:tests? #f ; no tests
+ #:make-flags
+ #~(list
+ #$(string-append "CC=" (cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure
(native-inputs
(list pkg-config))
(inputs
- (list wlroots-0.16))
- (home-page "https://github.com/djpohly/dwl")
+ (list wlroots))
+ (home-page "https://codeberg.org/dwl/dwl")
(synopsis "Dynamic window manager for Wayland")
(description
"@command{dwl} is a compact, hackable compositor for Wayland based on