aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 03:45:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 03:50:18 +0100
commit811b907da7bad99b7d7493623a0d7d61c388451b (patch)
treeae4cf4ad33577746a7430c4792c870ee9b8d09e9 /gnu
parentd100b9bd97f27cf3257b1b14bb0f9b27a966c27e (diff)
downloadguix-811b907da7bad99b7d7493623a0d7d61c388451b.tar.gz
guix-811b907da7bad99b7d7493623a0d7d61c388451b.zip
gnu: rclone: Update to 1.46.
* gnu/packages/sync.scm (rclone): Update to 1.46. [arguments]: Remove 'set-home-directory' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sync.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 421e362cde..d8789de2ce 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
@@ -249,7 +249,7 @@ over the Internet in an HTTP and CDN friendly way;
(define-public rclone
(package
(name "rclone")
- (version "1.45")
+ (version "1.46")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -258,19 +258,13 @@ over the Internet in an HTTP and CDN friendly way;
(file-name (git-file-name name version))
(sha256
(base32
- "06xg0ibv9pnrnmabh1kblvxx1pk8h5rmkr9mjbymv497sx3zgz26"))))
+ "1fl52dl41n76r678nzkxa2kgk9khn1fxraxgk8jd3ayc787qs9ia"))))
;; FIXME: Rclone bundles some libraries Guix already provides. Need to
;; un-bundle them.
(build-system go-build-system)
(arguments
'(#:import-path "github.com/ncw/rclone"
- #:install-source? #f
- #:phases
- (modify-phases %standard-phases
- ;; Fix failure during "check" phase: "mkdir /homeless-shelter:
- ;; permission denied".
- (add-after 'unpack 'set-home-directory
- (lambda _ (setenv "HOME" "/tmp") #t)))))
+ #:install-source? #f))
(synopsis "@code{rsync} for cloud storage")
(description "@code{Rclone} is a command line program to sync files and
directories to and from different cloud storage providers.
='msg-avail'>...* gnu/packages/aux-files/run-in-namespace.c: New file. * Makefile.am (AUX_FILES): Add it. * guix/scripts/pack.scm (<c-compiler>): New record type. (c-compiler, bootstrap-c-compiler, c-compiler-compiler): New procedures. (self-contained-tarball): Use 'relative-file-name' for the SOURCE -> TARGET symlink. (docker-image): Add 'defmod' to please Geiser. (wrapped-package, map-manifest-entries): New procedures. (%options, show-help): Add --relocatable. (guix-pack): Honor it. Ludovic Courtès 2018-05-07pack: Fix handling of '-e'....Fixes a regression introduced in aad16cc1965ab3488449c262455eb29b15c77e95. Reported by Julien Lepiller. * guix/scripts/pack.scm (guix-pack)[manifest-from-args]: In 'match-lambda', add clause for single packages. * tests/guix-pack.sh: Add test for '-e'. Ludovic Courtès 2018-05-07pack: Honor package transformation options....Previously they would silently be ignored. * guix/scripts/pack.scm (guix-pack)[manifest-from-args]: Add 'store' parameter. Call 'options->transformation' and use it. Move 'with-store' and 'parameterize' around the 'let'. * tests/guix-pack.sh: Add test using '--with-source'. Ludovic Courtès 2018-05-07pack: Adjust test to cope with GC'd profiles....Previous "test -x opt/gnu/bin/guile" would fail if the store item "opt/gnu/bin" points to had been GC'd. * tests/guix-pack.sh: Replace "test -x" with "test -L" to deal with store items that have been reclaimed. Ludovic Courtès 2018-03-24tests: Add tests for "guix pack"....* guix/scripts/pack.scm (bootstrap-xz): New variable. (%options) <--bootstrap>: New option. (show-help): Document the new --bootstrap option. (guix-pack): When --bootstrap is specified, use the bootstrap Guile, tar, and xz to build the pack, and do not use any profile hooks or locales. * doc/guix.texi (Invoking guix pull): Document the new --bootstrap option. * tests/guix-pack.sh: New file. * Makefile.am (SH_TESTS): Add guix-pack.sh. * gnu/packages/package-management.scm (guix) <inputs>: Add util-linux. Chris Marusich