aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrennan Vincent <brennan@umanwizard.com>2024-03-24 10:27:38 -0400
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:43:50 +0300
commit80f58e508f08e6424d3311f7c958d64fc6adf69a (patch)
treec7010bc5d46a4c865df37732956d79fcebe46065 /gnu
parent7758ad75f5d76207da700b9ebfbb7e1e85fb4d18 (diff)
downloadguix-80f58e508f08e6424d3311f7c958d64fc6adf69a.tar.gz
guix-80f58e508f08e6424d3311f7c958d64fc6adf69a.zip
gnu: rust: Update to 1.77.0.
* gnu/packages/rust.scm (rust): Base main rust package on rust-1.77. [source]: Remove another vendored copy of zlib. Change-Id: Ia4611b0ea153bce1de97e711af6d3f7396a6bf85 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rust.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index ba3253aa83..53bf4ee512 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -1027,7 +1027,7 @@ safety and thread safety guarantees.")
;;; Here we take the latest included Rust, make it public, and re-enable tests
;;; and extra components such as rustfmt.
(define-public rust
- (let ((base-rust rust-1.76))
+ (let ((base-rust rust-1.77))
(package
(inherit base-rust)
(properties (append
@@ -1050,7 +1050,8 @@ safety and thread safety guarantees.")
"vendor/curl-sys-0.4.63+curl-8.1.2/curl"
"vendor/libffi-sys/libffi"
"vendor/libnghttp2-sys/nghttp2"
- "vendor/libz-sys/src/zlib"))
+ "vendor/libz-sys/src/zlib"
+ "vendor/libz-sys-1.1.9/src/zlib"))
;; Use the packaged nghttp2
(delete-file "vendor/libnghttp2-sys/build.rs")
(with-output-to-file "vendor/libnghttp2-sys/build.rs"
@@ -1195,7 +1196,7 @@ safety and thread safety guarantees.")
;; The three tests which are known to fail upstream on QEMU
;; emulation on aarch64 and riscv64 also fail on x86_64 in
;; Guix's build system. Skip them on all builds.
- (substitute* "sys/unix/process/process_common/tests.rs"
+ (substitute* "sys/pal/unix/process/process_common/tests.rs"
;; We can't use make-ignore-test-list because we will get
;; build errors due to the double [ignore] block.
(("target_arch = \"arm\"" arm)